Audio Mixdown: thinks an External VST is in use even after Freeze

This is actually the second symptom of a bug I’ve reported to Steinberg before, to which I got a reply that that’s the way it’s supposed to work. No. No, it’s not.

Background: to use Cubase with an external synth or other MIDI thingee, you can either create separate MIDI and audio tracks or you can create an Instrument track, selecting “Steinberg | External Plugin | Cubase_MIDI_device_you_created_for_your_synth” as the VST. Instrument tracks have several advantages, including timing and level compensation, and only one track to deal with: you record your performance with MIDI, then Freeze the track to capture the audio - sort of like a very very handy Render In-Place.

When you Freeze an Instrument track, you are given several options, including “Unload Instrument when Frozen”. This is a very important option, because it releases those resources to be used on another track. If it’s a software VST, that free’s up RAM and CPU. If it’s an external synth, it free’s up that device (i.e., MIDI ports and audio channels), so you can use it on another track (Cubase allows only one instance of a MIDI device through “External Plugin” as described above.). I mean, that only makes sense, right? You’ve rendered the MIDI to audio; Cubase doesn’t need to hold onto those ports anymore.

HOWEVER, Cubase does NOT release the “External VST” devices after Freeze,even with the “Unload Instrument when Frozen” box checked. Steinberg tech support claims “that’s the way it’s supposed to work,” that doesn’t pass the laugh test. Why would it be designed to stay loaded, whether or not I choose to have it unloaded? It wouldn’t; this is a bug.

Today I found the second symptom of this bug, underscoring my point that this is NOT the way it is supposed to work. The second symptom of this bug is that, even when an Instrument track using an external synth is Frozen, Audio Mixdown insists that an external plug-in is being used, and therefore forces the render to be done in real-time.

C’mon, Steinberg, please fix the “Unload-After-Freeze” bug, such that External Plug-ins unload properly after Freeze, per the UI checkbox. These are more than just bugs; they’re loss of functionality.

It is by design, and extremely annoying.
Maybe a feature request would be more fruitful.

i have asked for this “feature” to be fixed/implemented/design-choice changed, etc. btw, software engineers are notorious for saying, “it’s not a bug; it’s a feature!”

yet if it were a feature / by design, then someone could point out a reason why that was a conscious choice. can anyone think of any reason why it is at all advantageous to not release External Instrument VSTs upon Freeze, when they are not in use at all??



I could not reproduce this, it unloaded properly.

unless windows and mac work differently? (which would back my claim that it’s a bug, not a missing feature)

to reproduce:

  • ensure you have proper MIDI Devices set up for your ext MIDI devices. I dont use any of the remote control panel stuff, but by defining a MIDI device, rather than just using the ports, is that you can adjust timing offset, match levels, etc.
  • create an Instrument track using External VST MIDI Device, eg to a synth
  • record some midi from the ext synth
  • Freeze the track, making sure the Release box is checked. This should release the MIDI Device after freezing (which literally just records the audio from he MIDI) but it does not.
  • Try to create another Instrument track with that ext device. You’ll see that the device doesnt even appear in the menu.