Audio output corrupted after sleep?

Whenever I try to resume my work after the computer has gone into sleep mode Dorico’s audio output is “dead” and I have to restart the program. I use Dorico with Noteperformer 3 on a Mac. Any hints to solve this?

Do you actively put your computer to sleep?
Due to Dorico’s audio engine your computer should never go to sleep by itself, because the audio engine will keep it alive indefinitely. Only when actively putting the computer to sleep it should do so.

And could you please do from the Dorico menu Help > Create Diagnostics Report and attach the corresponding zip file to a reply here? Thanks

And even better, together with the diagnostics please indicate when the last sleep was (about)

Yes, I put the computer manually to sleep. Should I avoid this? In this case I would have to quit Dorico before interrupting my work!
My last (computer-)sleep was 12 hours ago (before going to bed). I attach the report now.
Dorico Diagnostics.zip (2.0 MB)
Thank you for your help!

Thanks for the data, but the log files show me somehow something different.
Yesterday you started a Dorico run in the morning until 19:25 in the evening. That’s when you shut down Dorico and started it up again very soon after. Then Dorico and the audio engine were running basically the whole night until 11:10 this morning, where you stopped it again and yet started with a new session immediately again.
So, over night the audio engine showed not much activity, but there are regularly log messages the whole night over.

Could you maybe please do the whole thing again, maybe during lunch break and write down when you manually put your computer to sleep (and woke up again)? And of course send a new set of diagnostics. Thank you very much.

Ok, now I interrupted my session for lunch 40 minutes ago, I put the computer to sleep mode manually, and now the output is muted. See the report attached.
Dorico Diagnostics.zip (2.4 MB)

Many thanks again for the data. Unfortunately they don’t show anything unusual.
However, I just did some testing with my own MacMini and ran into a similar if not same issue.
My next question is, do you have some wired headphones connected to your Mac.
If so, that might be the problem.
Because I did play out via the speakers and at the same a wired headphone was connected. Then I put the Mac into sleep (for one minute or so), woke it up again, and similarly, no sound came from the loudspeakers when hitting Play again. What happened was, the sound now came out of my wired headphones.
To fix this I went to Edit → DeviceSetup, click on the Device Control Panel button and in there changed the tickmark from headphones to speakers. Close the two little windows and sound was back to the speakers.
How about in your environment?

Yes, I have active speakers connected to the Mac’s headphone output. And it seems that there are 2/3 issues:

  1. the muted output
  2. the changed output which persists after Dorico’s restart.
  3. And I have another problem: after sleep I have to unplug/plug the midi interface to make it work. This however is Mac’s problem (it occurs in Finale and Audio-Midi-Setup as well). I can live with that…
    Thank you for your support!

Hi @lim.usic,
regarding the muted output, well, it’s not muted, it is just routed to a different out port than you expect. You then just need to go to Edit > Device Setup, in there click on the Control Panel button and in that new little window that pops up, choose the wanted output ports.
I know, this is by far ideal, but we are already discussing internally on a better solution for this.

Regarding your second point, well, Dorico (or its audio engine) always tries to recreate the connections that it had as last configuration in the previous run. So this behaviour is fine.

And the plugging of MIDI interfaces looks like a general problem with you, nothing Dorico specific.

Possible hints only: The device swap could be a clue that the audio device and usb midi are sleeping , or at least it reminds me of a time when I had to adjust the power saving / sleep settings of my laptop. Basically on sleeping the power settings would power down peripheral systems but the Dorico engine ( since it was still running) would apparently consider them failed or not available. Least ways for me, adjusting the power settings resolved it. ymmv

I’d like to confirm that this is also happening to me. After the computer sleeps, the audio reverts to the Mac mini internal speaker (which is very sub-par) instead of my connected speakers attached to the audio port of the Mac mini. I have to go in and reconnect the audio in System settings and this usually fixes it (albeit an annoying thing to constantly have to do). Today, I couldn’t get the sound to work at all (through the speakers) even though the sound in System settings shows “External Headphones…Headphone port” — but sound is routed to Mac mini speaker. If, as an experiment, I open a web browser and try to play a YouTube video, the sound plays perfectly through the speakers.

Dorico Diagnostics.zip (745.9 KB)

I can’t offer any explanation for this behaviour, I’m afraid – perhaps @Ulf can tell what happened from the audio engine logs?

Hi @musicmaven1 ,
to be honest, I can’t explain that either. See, Dorico’s audio engine doesn’t know anything about internal or external speakers, it only "sees"the Built-in Audio device. Where that device is wired to gets decided by the Driver Control Panel; Dorico has no means of controlling that.
And I also tested this with my M1 MacMini, I force sleep the machine, wake it up and it continues putting out sound to the same physical output as it was before the sleep.
Could you please make another diagnostics report directly after having had such sound issue? Thank you very much.
But I suspect I won’t find anything in the audio engine logs. We then probably need to enable logging from the CoreAudio2ASIO component, but let’s take it step by step.

Thanks, Ulf, for checking on this. I started up Dorico this morning and had to go in and move the volume slider in the Sound setting of MacOS and this enabled sound through my speakers instead of the Mac mini’s internal speaker. Strange… but I’m thinking this is a Mac issue now.

Upon reflecting…I understand we mere users of technology don’t always comprehend how difficult it must be to get all this hardware and software to work together; yet here in the year 2024 I’m surprised that something so basic as getting sound out of attached speakers should be a challenge for a company like Apple. I’m a little flabbergasted!

Oh well… there are other, bigger problems in this world.

Thanks again Ulf - you are the best!!!

You are welcome!
And it is indeed like you say. We are able to build AI like ChatGPT and yet struggle and fail with such basic stuff like getting sound out from our computers. Certainly a strange world it is.
But what a nice word, flabbergasted…I’m a German speaker and never heard that word before, I have to remember that :smiley:

2 Likes