Audio performance issues [solved]

Hello, friends -

I’m having some regular audio issues - sluggishness, drop-outs, etc. I have been trying to nail down the reasons, and have tried several fixes (and, Leo, I did search the forum :slight_smile: ), but I"m stumped.

I’m running 2.2.10 on a Windows 10 i7 laptop (eighth-gen, 4 cores). 16G RAM, 250 G SSD.

It’s a concert band score, but at this point I’ve only used about 8 instruments at one time.

There are three instances of HALion running. No extra VSTs installed.

Sometimes there a lag when changing tabs, sometimes I get “not responding”.

Autosave is off.

Looking at system monitor, the CPU is never higher than about 46%, and memory is fine.

I can be playing the piece, and it gets to a section with some quicker notes, maybe with an accent or two, and the playback just stutters or stops for a second.

Oh, and I tried increasing the audio buffer size, nothing changed.

I am officially stumped. Any thoughts?



Try changing some of the options in the HALion Sonic SE plugin. The options button is in the top right of the HALion Sonic SE window. There are various options to change the maximum number of voices, uses of RAM vs disk and multithreading. Try the multithreading switch first. Also in the top right there’s a readout of the maximum voices in use, so keep an eye on the peak values as you play back. You only need to change the options in one instance of HALion - it will apply to the others too.

Paul means the Multi-Core switch in the HSSE options, but don’t set it to max, just 1 less.
Furthermore, to what buffer size is your audio device set? Increasing the size might also ease the cpu load.

Thanks, guys, I’ll check it out.


Well, now that I know WHERE the HSSE options are (who’da thunk, they’d be under the word “Options?”) . . .

Multi-core for audio was set to “off;” I set it to 2 cores, and everything just worked.

There’s always more to learn about this great program.

I love you guys!