Audio Performance question

Hi, just technical question: does it make sense the Overload indicator (CPU part) is constantly lit (I was experimenting with Audio buffer so using UR824 I set the 32 samples “Low Latency” mode) but the meters of CPU load are really low (so I cannot catch the ide how it is possible). ASIO Guard switched off. Cubase Pro 11.0.41, Win 11. Latest UR824 (Yamaha) driver version. Played only 1 stereo audio track (44100/16), no FX used.

Even that I was a bit surprised my system is not able to handle this easy task (i9/10850K, SSD disk, 16GB RAM).

Thnx for any ideas. I do not need working in such low buffer setting but it is a bit interesting to me.


Yes it makes sense. The VST meter isn’t measuring the same thing as the task manager CPU meter (in Windows).

Hmm - it sounds like I did not write it correctly. I am discussing only the items in Performance window - no comparison with anything inside Windows.


No, it indicates there is something wrong.

The USB port, the mainboard, ASIO drivers and the interface itself are way more important than the CPU, RAM or SSD in this case.

I think so - but I would suppose the bar indicator would be much more higher (or at least changing its state from let`s say full to minimum) but it is staying with really low level and only the red indicator lits. Maybe anyone with UR824 would be the best in the discussion. I do not have any idea actually since the problem is related to the minimum settings of Audio Buffer only. Hmmm…srange.


That is it. I added the rest of info just fot “to have the complete information” :slight_smile: hmmm…will do some research if I have a time.


Oh, I see. My bad.

I think it still makes sense. If you have a bunch of tracks all running in parallel with a moderate amount of plugins on each track I would expect the average load to increase compared to if you had fewer tracks. When you lower the buffer I would expect the value on the “real-time peak” section of the meter to go up because the demand on real-time performance increases. Same thing if you increase the chain of plugins or use more demanding plugins - basically stressing a single core more.

And therefore if the load on a single core is high enough you get the OverLoad indicator lighting up, and I suppose that could happen while the average load is low - for example if you have fewer tracks but with really long heavy plugin chains.

So to me it makes sense.

Just as an after thought you are resetting the indicator light aren’t you?
It stays red after there has been a Performance spike.
Apologies if you know this already.

Of course I know but thnx anyway for your reply. Because of there is still the Overload clicking the light has no effect.


Hmm…interesting and OK, I can get it. But - as I add the Project’s structure - I expected one stereo track with standard resolution (in sample rate and bits) will be no problem for the soundcard and the system. Otherwise it makes no sense to me such this buffer setting if the system cannot handle it properly. I guess there is something “in behind” what I do not see or whatever…


Reading your first post again, are you saying you have the buffers set to 2?

Oops…!! :smiley: thnx, mistyping of course. 32 samples (I edited it actually).


So I read your first post again, and perhaps I missed it earlier. I guess there are two thoughts in my stupid little head - first what I said before that the meter itself makes sense, and second that if you actually get dropouts with only one track and zero effects at only 16/44.1/32 samples then ‘yeah’, something seems to be up. I would expect you to at least play that back or record a single track (analog) with those settings.

Like st10ss wrote I would probably look at the USB port you’re using as well as a few other things. A lot of motherboards these days will have some USB ports go through the chipset and others go straight to the CPU so it’s worth trying different ports I think.

Other than that I don’t know, but it’s a bit weird… unless that CPUP sucks…

The differences are the connection to the PCIe bus… some are located in the chipset with direct access to the PCIe bus (close to the CPU) and some are realized with an extra controller chip on the mainboard, sharing the PCIe lanes with different I/O chips.

That’s not how I understand it. At least on AMD’s AM4 platform the i/o control is in the CPU for the USB ports listed as connected to the CPU, and the rest go through the chipset.

I would have guessed it was exactly the same for Intel.

I will investigate it…
Maybe my informations are outdated…

Ok, I researched a bit…

It’s a bit strange that Intel is providing support for USB-C inside the processor, but no USB-A support, no matter what revision is used… still located in the xHCI of the chipset.
So USB 3.2 over USB-A connector is located in the chipset, USB-C is supported from the CPU (also TB3 or TB4 and of course USB4.0)

Hmm - nice discussion I would say men! Thnx for the tips and deeply research (even I have 2 USB ports free I see I did not have the idea to change it; both are USB 3 - I connected the UR824 to the USB 2 of course because I had read a few notes in the past even the backward compatibiloity should be there people encontered a few problems when connecting such device like soundcard to USB 3 port when it was designed for USB 2). Will do some tries as I promised and will let here know the results :slight_smile:

OK, after some research and (re)plugging into different USB ports I have to say there is no change and my Audio Performance window looks like this (after creating new empty Project):

Tbh - no drop-outs hereable when playing the audio track. Dunno where might be problem. WaveLab (11) is OK if we are discussing the Performance meter, Reaper the same (it reports something like CPU usage <1%). Only Cubase has this presentation. I left my UR824 in USB 3.2 port actually.

Thnx for any other ideas what to try or so.


EDIT: Found simillar topic here (processing overload - #16 by mark_w_w) - it seems like bug or at least “Cubase reports something unreal” :slight_smile:

EDIT2: It has the relationship definitely with the driver. As soon as I switch the mode to either “Standard” or “Stable” then red lights disappear after clicking on them, meters (CPU load) shows the same (approx) levels still and no red indication at all. So maybe it helps to anyone with UR line soundcards (the driver seems to be the same).