Audio Performance reading

Hi
The top 3 bands of the auido performance are nearly 50% in a small project of about 35 tracks using VST instruments, samples and audio.
Are there any settings to the computer that can be tweaked to lower this ?
I’m running Cubase 12 pro and Windows 10 and have done all the usual windows set up.

Hi @ADRIAN_DIX

There are several options to optimize performance, increase the buffer size for playback would be one:

I’ve tried different Buffer settings and the results aren’t much different.
Are the BIOS settings still necessary now that we’re at Cubase 12 ?


Is this OK ? for latency etc ?
Or, should I keep tweaking

Hi @ADRIAN_DIX

What are your system specs and OS?

When you are done recording, latency doesn’t matter anymore. Thus, you can put it to the max value.

If you are still recording, try to identify what is the most resource hungry track. You could freeze/disable every synth track one after another and identify the culprit like that.
Once identified, freeze those particular tracks.

I’m just trying to get an indication of what the ASIO guard should be.
Most of my projects are much the same as this one.
Do people have better latency readings or worse or is there no criteria ?

Is there an actual problem like clicks or dropouts or something?

Hi
No, So I’ve decided to leave it.
I expected more from a new build machine.

If you have no problem and want to lower latency you can try to turn ASIOguard off completely, make the buffer(s) smaller, double your sample rate (though it’ll probably close to double the load on the CPU), or any combination of the above.

Just in case you didn’t know, the performance meters in version 11 and 12 work differently anyway, and are not directly comparable.

OK Thanks.
I’ve decideddto leave it alone as it’s working

1 Like

Is the meter a bit wonky in Cubase? I recently got Cubase 13 and I’m finding the Audio Performance meter in Cubase to be a lot more random than the one in Studio One. The more plugins I use the more it seems to calm the meter down and bring it back to a more sensible level in Cubase. In Studio One the meter has a very small % register doing the same thing from the start.

Cubase 13 with one instance of Dune 3 idle
cubase

Studio One 6.6 with one instance of Dune 3 idle
Studio one

Perhaps they are not measuring the same thing?
The Studio One meter is labeled “CPU” whereas the Cubase one reads “Audio Performance - Real Time/ASIO Guard/Peak”.

Thank you for the reply. Oh I see so the cubase meter doesn’t represent the CPU usage? I think I’ve got confused then.

Correct. It takes the entire chain of audio computation into account. It makes sense if you think about it because you can experience audio dropouts in a DAW without maxing out your CPU.
Also note the difference between having tracks Record Enabled (or Monitor turned on) and not. The former routes audio via the real time engine and latter via ASIO Guard.

1 Like

Brilliant thank you for explaining. I was getting a bit twitchy with the meter :sweat_smile:

After playing some more it seems the meter calms down when I add more instruments. Does this mean Cubase starts using more cores?

Also If I change a preset on a synth in Cubase while the track is playing the meter can hit red (processing load meter) Something that never happens in S1. I have a AMD Ryzen 9 5900X 12-Core Processor 3.70 GHz.

This is with a copy of bx_oberhausen, Jupiter-8 V4, Pigments, Drumazon 2 & Repro-5 playing all at once. Pretty good and I probably have to get used to the dancing meter in Cubase.
tes screen

Unfortunately Cubase does not have a “gapless audio engine” which I believe this behavior could be attributed to.

Unless you’re experiencing some abnormalities and audio dropouts, I would just get rid of those meters. It’s nothing worth stressing about.

1 Like

Thanks for explaining and you’re right. I will hide the meters away :+1: