Audio Performance?

I try to understand why some projects burden my setup very much.
I have tested with Cubase_10_5_Demo_Project_Paul_Marx_Media and it is not possible to play without performance peaks and audio breakups.
Attaches two pictures that show what it looks like when the song is stopped and when it is played. Why is it so high load even when nothing is being played? By eliminating various plug-ins I have found that Tap Delay seems to be responsible for a large part of the load. I know I can freeze tracks and render in place, but I think this project should be able to play smoothly in my system. Any suggestions? Yes, “Suspend VST3 plugin processing…” is enabled. WiFI off, no antivirus, unused processes is disabled, all cores are parked etc.


That delay you found (plus most all your other plugs) is still running even when Cubase isn’t playing back. Think about it - if that delay or a reverb were being applied to a vocal Track you’d still want to hear it when monitoring the input signal while stopped. The singer will want to hear themselves sounding the same in their headphones independent of if the Transport is running or not.

What is then ”Suspend VST 3 processing when no signal” doing? No tracks are armed, nothing playing hence no signal or am I misunderstanding this completely? I’m just trying to understand. In order to solve this, do I need more ram, better CPU or what?

In theory it should stop the processing, but as your own detective work shows it doesn’t always happen. I suppose there could be a variety of reasons like; some VSTi’s and effects always generate output even if it’s too low to be audible, especially if it has some modulation going on; the plug-in isn’t designed or improperly implemented to respond to a request to suspend; if Cubase isn’t sure the safer course would be to not suspend. What happens if you mute everything feeding the delay?

The classic way to resolve this is to render & disable the offending Track(s) but there are lots of times you might not want to do that. Do you have ASIO Guard on? Some folks get better performance with it off or with different settings - so that is worth tinkering with. Keep in mind that the Audio Performance Meter is looking at a mix of other system resources beyond just CPU.

A lot of playback performance issues are resolved by increasing the buffer size in your audio interface. But the downside is that increases latency when recording. It’s not uncommon for folks to switch buffer sizes for different tasks.

Task Manager indicates you’ve got a bunch of unused memory & CPU so I suspect adding more wouldn’t directly help. Sometimes one core ends up maxing out while the others are OK and that won’t be visible in the total CPU number, but will show on the Task Manager Performance tab.

If this is a one-off problem I’d recommend rendering and moving on. But if it is chronic you’re going to need to investigate to figure out where the bottle neck is occurring. From what you’ve posted it doesn’t appear to be lack of CPU or memory (but additional info might change that) - purchasing additional memory or CPU only to have it remain unused doesn’t really help anything.

Good luck

Hello,
Thank you for taking the time to answer this. Actually, this is not a critical issue because there are workarounds just as you mention, but I’m to curious to not investigate this further :blush: . I have tested all possible (afaik) settings, ASIO-gard on / off; different buffer sizes etc. It gives only minimal or no impact. Mute all tracks with delay gives no impact or even a little worse(really strange).
It’s just that there is something wrong with either my system or Cubase and I can’t let i go :blush: .
You do not happen to have tested that project in your system? It is one of the projects found in this thread, https://www.steinberg.net/forums/viewtopic.php?f=283&t=177131. As far as I can judge, isn’t it particularly heavy?

Curiosity killed the cat!

The Suspend VST3 plug-in… parameter has a very clear effect, here, on the audio performance (Cubase Pro 10.0.50) : worth a check…


Still wondering what this one is supposed to improve, actually… :confused:

#cubic:
Are you running the same demo? Your meters are way below mine both with and without suspend

No, it’s not the demo that you are using. Actually, it’s a template of mine with several VSTis and FX loaded. But I think it clearly shows that something is wrong with this parameter : I shouldn’t get a more than two times audio processing load amount whan activating it…
Apparently, this is a 10.0.50/10.5.0x bug that is supposed to be solved with 10.0.60/10.5.10. Just hope so, because the difference between activated and not is ridiculous : how can something like this pass the beta tests stage ? :unamused:

Hm. cubic13, this is a test I haven’t tried - that’s crazy! So Why haven’t you installed 10.5.10 to check if this is an improvement?

Because I’m still using the 10.0.x generation. From which, my waiting for 10.0.60, which is supposed to be the last update of it and also fix this bug.
It’s not a showstopper, far from it : I just had to untick this parameter to make things normal, considering my new system specs. But again, I’m still wondering what this parameter is here for…

Beside this, seeing feedbacks here and there about it, I’m not in a rush to get 10.5, honestly…