Audio pitches down when headphones are plugged in

Hi,

I’m running Cubase 12.0.52 on a MacBook Pro M1 Max, OS Ventura 13.3.1. I’ll try to explain the issue as best as I can.

There’s a huge problem with audio when it comes down to change the audio driver. I usually opt for a Focusrite Scarlett 4i4, and everything works fine. When I unplug that to work with the headphones jack output (maybe because I’m away from the studio), sometimes it doesn’t show any outputs. Meaning, the audio built-in is selectable in “Studio setup”, but when I set the outputs up in the “audio connections” window, it doesn’t show the built-in L and R channels.

I still don’t understand what’s the correct way to solve this, but I found out that unplugging and replugging the audio jack magically makes the outputs appear. It’s either that or doing the same thing with the Scarlett. I know it’s confusing but usually, playing it like that solves the issue, it’s not ideal but enough while I wait for some kinds of updates.

Lately, however, something new came up. If I don’t have the Scarlett connected and outputs are showing up correctly, and I play cubase via the built-in speakers, audio plays smoothly (it’s just a piano VST in the session I’m using now). If I plug in the headphones (without Scarlett), the audio suddenly pitches down and slows down A LOT. I thought that was some kind of mismatch with the sample rate, but there are no issues in the “project setup” window.

What is happening here? Anybody has any clues?

EDIT: I just found out that changing the Sample Rate to another value and back to the original one solves this. In my case, it was at 96 kHz, I switched it to 48 and then back to 96. However, this is highly far from ideal, it worked on that session because I did not have any recorded audio (just one piano VST), I honestly don’t want to do that if I have audio tracks as it might mess the project up converting the audio.

Hi,

Make she the Sample Rate of your project matches the Audio Device’s Sample Rate.

This is what it looks like. Seems fine to me.

Yesterday, I used the Scarlett and quit cubase, with the audio interface set as that one.

Today, I ran Cubase again, with headphones plugged in. Sound was coming out of the speakers, weirdly. I unplugged and replugged the headphones, now it’s going through them, but I have the same issue as usual (sound is slowed and pitched down).

This is seriously annoying. What am I missing?

EDIT: again, changing the the project sample rate to another one and back to the original makes time and pitch issues disappear, but I’d hardly call that a solution



This is also happening to me regularly (picture below). I somehow manage to resolve this by restarting Cubase or opening a new project with a different sample rate and re-opening the old project.

The most annoying issue for me though is the auto-switch not working properly - e.g. if I save a project without headphones plugged-in, next time I open the project WITH plugged headphones, it doesn’t switch automatically to headphones. I need to open Studio setup → Control Panel and manually click on the Headphones output checkbox.

This used to work flawlessly on all of my previous Cubase versions / older OSX’s. I mostly use Macbook’s built-in audio and would like Cubase to immediately auto-switch from speakers to headphones or vice-versa.

@Martin.Jirsak any ideas? I don’t believe this is OS realated.

Cubase 12.0.70 on Monterey 12.6.3

Interesting that you two outputs are showing different sample rates

1 Like

Hi,

Which headphones do you use?

I’m not expert in this area, but if I’m not mistaken, macOS handles the speakers and the headphones as 2 Audio Devices. This is new since macOS 10.12 (or something like this).

1 Like

Hi Martin,

Thanks for your quick reply. I’m using Sennheiser hd 58x and sometimes AKG K-702, both regular cable (no bluetooth connection or such).

I’ll look into the macOS handling those two as 2 audio devices thing. I also have an older Macbook Pro with Sierra (10.12.6) + Cubase 10 and on it the auto-switch works perfectly. A friend of mine who also has Cubase 12 on Monterey, but on an 2019 Intel Macbook Pro 16", has the same issue. I’m on M1 max 16".

Do you know an expert in the area who could help? Many thanks,

Ivan

Hi, i have same problem and any resolution.:confused:

Hi and welcome to the forum,

One of the device is working in 44.1kHz the other one in 48kHz.