Audio processing not working

Cubase 8.5-when I try to apply processing to any audio track(DC offset,silence,normalize,etc.) nothing happens. Works on some projects,others it won’t. All projects I have worked on,audio tracks have been imported into the project. No projects are over 8 tracks in size,as they are all taken from an analog 8 track. Some projects all 8 tracks are imported at the same time,some one track at a time. Processing problem seems to be random among projects. I’ve used Cubase templates for projects and the empty template also.Cant figure it out.Am I missing something obvious?


Audio processing are not applied to the tracks, but to the Audio Events. Select any Audio event (region), and apply the process on it.

Thanks for the response,Martin. Selecting the audio event and trying to process doesn’t work,either.what is strange is sometimes the particular processing window,for example,DC offset,will pop up.after hitting the process button,the window disappears,but no processing is applied,even though in the edit menu it shows undo for the processing I just tried to apply! Some projects I have started with an empty template and imported all 8 files at once.For some reason Cubase thinks it is one file,even though they are imported onto 8 separate tracks.I have imported files one at a time and it still won’t apply processing.I have also uninstalled and reinstalled Cubase.Some of my projects processing works on,some it doesn’t,so I must be doing something different but I can’t determine exactly what that is.I did start out with Cubase Artist,immediately upgraded to Cubase 8 Pro,then to Cubase 8.5 when it was released.Don’t know if that is relevant.Sorry for the long post.


Could you try it for example with Fade-In or Recerse or something obvious? DC offset could be hard to guess, if it’s applied or not.

So the window with the process appears. It is in the history, and it is also in the Process History, right? It just seems, it is to applied to the Audio part. Am I right?