Audio quantise on Cubase 7.5

Please, please somebody help. It will become clear to you all, pretty quickly, that I am useless with Cubase, although, I am trying, honestly I am. My problem is this. I record my acoustic piano, on an audio track, and when I listen to it, it’s obvious that there are several points, where the timing of my playing, is slightly out, so I highlight the track, go to edit, open up quantise panel, and no matter what setting I put the note value on, I hit quantise, and it makes no difference whatsoever. I also have the audio button, that I can’t remember the name of, activated as well. Am I doing something wrong, or is it that Cubase can’t alter what I’ve played on the piano. I’m really hoping someone can help, as I’m seriously considering, taking my computer, and all the other bits and pieces, that are connected to it, down to the garden shed, and beating it to death. Thanks very much.