Audio recording: Have signal in, but no signal captured in channel

Sorry - Ex-Sonar Noobie here with a naive query. I have a problem recording audio. I have already recorded an audio signal and it plays back fine, so I’m sure drivers areall ok (Yamaha Steinberg USB ASIO). However, now I’m trying on a new track, another audio channel, and some setting must be upset somewhere. I can see the audio signal coming into the correct channel - the VU meter fluctates well, and I can hear the signal through the output (Stereo out VU moves as well). However, no signal is caprured in the channel - all I have is just a flatline when I’m recoding.

The channel is armed and the corect buttons have been pressed. I’m sure the routing is correct: Routing In =Mono 2 in from my UR-22 right channel. Out=Stereo Out; monitor and red “armed” buttens pressed. Then when I click record button, nothing is captured. The menu for Studio/Audio Connections seems to be OK (as I said, I’ve already done some successful recordings). So now I’m baffled.

Thanks for any help

Are you sure there is no audio recorded…I suspect you just have missing visible waveform as this bug.

Well, fancy that.Thanks for the link. I’d seen these post titles but not linked it to my problem.
Sure enough, when I zoom in, the waveforms are there and it is recorded.
When I open a new project, it’s all ok - probably no image folder there at the start.
I hope they roll out the fix soon.
[thinks … how long would the guys at Sonar let this drift? … nevermind]

Thanks again

Have you tried the fix suggested in the thread linked by Grim? Record in 24 bit? If that doesn’t fix it then it’s probably something else.

Yes thanks. 24 bit fixed it. I’m still playing around and finding things on Cubase, I’d switch to 24 bit anyway for when I start full recording.

Thanks again