Audio recording out of sync

hi there , since upgrading to 6.5 ive noticed when i record my guitar then i listen back it appears to be playing back slightly in front of the beat ,i think i came across this once before in cubase 4 but cant remember how i sorted it out, anybody help, thanks.

Could well be that “use system timestamp” has become unticked during update??

I once accidentally hit the time offset slider when I was working very quickly thinking I was changing the panning.
It took quite a while to figure out that I changed the offset instead.
Good luck
S

thanks for your reply “use system timestamp” was always checked, but it seems like a similar problem . i also came across this a year or so ago when using a E-mu 0202 usb soundcard , and it was realy bad i had to drag the audio back into sync, it was also ahead of the beat . i use a E-MU 0404 pci sound card , maybe it could be something to do with the soundcards .

thanks for your help ,but it wasn`t that .

hi there, is anybody having any out of sync problems when recording audio with e-mu 0404 pci card and cubase 6.5,thanks.

I assume you checked all the obvious stuff such as having the correct driver selected…did you try a different buffer size?..do you have anything in your “Adjust for Record latency” option??

If the amount the audio is out is always the same then you could adjust the record latency to a minus figure to sort it, but as you have early audio rather than late it suggests some other problem so not sure if I would trust this 100%.

If you want to try it, to accurately set this figure you should run the audio loopback test below.

I always run this on every new computer & set my offset no matter how small…while you may not really notice the extra 1 or 2 ms difference that you will possibly find even if your driver latency is being reported & adjusted correctly by Cubase, there is certainly no harm in eliminating it either.

ftp://ftp.steinberg.net/Download/Test_Projects/
http://forum.cubase.net/phpbb2/viewtopic.php?p=23991#23991

Thanks for posting that Grim. That audio loopback test was very confusing, with some posters saying that different offsets have to be applied for different recording situations. I guess it makes sense, but it I’'m wondering if it’s just as easy to shift everything as needed after recording.

I think I’m going to check my MIDI/Audio timing in a decidedly analogue way - hit a key on my MIDI keyboard hard enough to pick up the sound on my mic, and see where the key strike lines up with compared to the MIDI note. (I thought of that after listening to Ray Charles’ “What I’d Say”, where you can hear his actual keystrikes. Like being in the room with him!)

Note that with the speed of sound as it is, you can get a few ms of delay between key and mic too!
But if you place it very close it might give an indication, as long as Cubase is set up properly to compensate for the input latency of your audio interface.

hi grim thanks for your reply , i did a quick test with a E-MU 0202 usb card ,please correct me if i have set this up wrong … i took a lead from the headphone output of the E-MU 0202 and fed it back into the input of the 0202 ,i have probably done this wrong because of the direct monitoring? anyway the results came back as …pre -recorded cowbell 10,000 samples , my recording -6800 samples. so mine is 3200 samples early. the figures i noted are correct . i typed in -3200 samples on the devices /VST Audio system /advanced options /record shift, and it went miles out . i`m probably doing something wrong here.

Thanks for posting that Grim. That audio loopback test was very confusing, with some posters saying that different offsets have to be applied for different recording situations. I guess it makes sense, but it I’'m wondering if it’s just as easy to shift everything as needed after recording.

Different offsets do not need to be applied for different situations unless you are incredibly anal. For different hardware setups yes…each combination of PC & interface will produce different results. It’s possible that your card may also differ with different buffer settings but these differences are likely to be too small to matter…tbh if your card is working properly then even the initial setting should be very small…on the forum I see 55samples, 88samples…my own offset is 109 samples…these are all less than 2ms which is pretty imperceptible to most people. The OP has a much larger problem which really ought to be solved at source rather than compensated for, but difficult to say what the cause of it is.

i typed in -3200 samples on the devices /VST Audio system /advanced options /record shift, and it went miles out . i`m probably doing something wrong here.

I would keep trying till it makes sense. Check your results after the changes because if you set -3200 record shift there should definitely be a 3200 sample difference (give or take a few samples) from your first result if you run the same test…did you just get your figures the wrong way round maybe??

hi grim, thanks for the audio loopback suggestion ,as it turns out my xp 32 bit setup with cubase 6 and a half, plus the E-MU 0404 pci card was suprisingly very good, only 5 samples out . but the E- MU 0202 USB card on windows 7 with cubase 5 was a few thousand samples out and to get it somewhere sensibly lined up i had to type in minus 500 samples which made no sense … this then put it after the original signal by 200 samples (head fuck).anyway as somebody on another forum pointed out the usb cards are very erratic ,so it`s got a new job as a door stop.thanks for your time.