Audio render does not include all note events when Piano Roll opened and on "Solo"

  1. Create A new project
  2. Add a Midi Track with Software Instrument
  3. Record a few Midi Notes
  4. Cut this MIDI clip in half, make sure the selection/cycle marker is set to the whole length of both clips
  5. Open The Piano Roll of first half
  6. Set Piano Roll on “Solo” so only the first half is audible in playback
  7. Now Render The Whole Track

What is supposed to happen:

Audio Render should simply render all audio, no matter what I have currently visible in my Piano roll (that should only concern playback)

What instead happens:

Audio Render includes only notes visible on screen in my Piano Roll window and the “second half” of my recorded events just doesn’t go into the render.

Cubase Version: 12.0.70 (Mac)


Isn’t this a duplicate post? It sounds familiar to me.

Haha…is it? I admit I did not search for a similar issue when I reported this yesterday. Also I thought, if it still persists in the most recent version of Cubase, it probably hasn’t been looked at yet.


Before this step, you unselected the selected MIDI part, correct?

When you do this, you are still in the piano roll of one of the midi clips you are editing. You simply go into File → Export → Audio Mixdown. Keeping the piano roll open at this point is crucial.

Only the midi part you are editing is selected.


So not Render, but Audio Export Mixdown instead?

What do you mean by “whole track” then, please?

Sorry, your description is quite misleading.

For me Audio Render is the result you get when you do an Export Mixdown. The DAW renders the audio output into a file - hence, this is called Audio Render. I am sorry if that confuses you. I have been working with a lot of video editors in the past and this just has turned into my own jargon at this point :stuck_out_tongue:

With “whole track”, I mean the entirety of midi events that are in the created cubase project. Both halves of the midi clip

My issue here is that, as long as I keep the piano roll editor open, it takes direct influence on how the audio mixdown turns out whereas this should have no effect on it at all. I get it that when you Solo something in the main track view, it only renders out all the unmuted tracks into the mixdown. But if you’re just quickly editing something in the score editor - like how I did yesterday when exporting a music loop for a game and had to edit the very first note just so it would not cut off the note too much, I left the piano roll open and exported the whole arrangement as I was doing several exports one after one until I had the best result. So basically, if I wanted to have everything exported and not just the section I was editing, I should have closed the piano roll every single time I did an export? I am really not sure if this is a bug or a feature …

There is a function called render in place that uses this terminology.

Maybe different vendors use different wording, in Cubase and Nuendo this is called Audio Export.

If you have solo enabled for the editor, it can have an effect on the outcome.
There is a setting that enables solo for the editor if you open it. You need to deactivate the solo state then.

Cubase uses the left and right locators as the borders for the range that will get exported.
But there are possible preferences that have an influence how the locators get set.