Audio starts creating artifacts during output (UR12)

As title says. To go more in depth it’ll be fine for anything up to possibly 15 minutes, but sooner or later, there will be little high pitched ticks and squeaks that start to increase in frequency until it sounds like full on bitcrushing distortion. A similar sound would be I guess the interference some smartphones can create when too close to an input line (and I’ve tried to rule this out by placing the UR12 in various places around the room away from potential causes of interference) with the cellphone elsewhere in the house). Sometimes this takes a few minutes to escalate to this level, sometimes it’s in a matter of seconds. It often comes back down a bit and almost resolves itself, but never completely and makes a resurgence a small time later. The sound I’m listening to when it happens doesn’t actually appear to be affected or anything, this just happens over top and it’s OBNOXIOUS.

I’ve tried turning the buffer up (right now it’s maxed at 2048 spls @ 44.1khz) but it doesn’t help. I’ve tried it with both direct monitoring on and off and it made no difference. It does it for both playback inside of the daw, and listening to, say, a youtube video. Oddly enough, it has yet to happen while recording a track, even with the metronome running. It does this both with and without my DAW (reaper) running.

Interestingly enough, I inadvertently found a temporary fix for this issue by either launching my DAW (reaper) or going into its audio device setup which seems to “refresh” the ASIO driver. It’ll immediately clear up the distortion sound, but it only works for a short few minutes before it inevitably begins again. I can go into the audio device setup menu or relaunch the DAW as many times as it takes to clear it up, there’s no diminishing return or anything, but it’s still quite an annoyance when playback on a recorded track needs to be halted so that I can access the ASIO driver’s settings page again to reset it.

My PC is an Asus M5A78-M-LX Plus motherboard with an AMD FX 4100 3.6GHz processor, 16 GB of Ram, a 1TB Seagate HDD, running Windows 7 x64. All audio drivers and the steinberg UR12 drivers are up to date. Would rather hold off on a BIOS update as I don’t know which one would actually fix it if it is a bios problem.


EDIT: As per a recommendation in another thread over a similar issue, I rolled back the driver to the version that comes on the CD out of the box (1.9.4) and all issues cleared up, so apparently it’s an issue with driver version 1.9.6

Just bumping this and pasting the link to the other thread in case it’s useful to anyone else:

https://www.steinberg.net/forums/viewtopic.php?f=157&t=89056

Thanks