Audio sync problem that previously wasn't there

Cubase 7.0.7 | iMac 27" 2.9GHz Intel Core i5 | 8Gig RAM

Hi all,
I’ve seen that a couple of people have posted issues similar to this from what I’ve seen, but on reading the posts, I haven’t seen a full solution. Anyway, my problem is thus;

I have used both the official Cubase template for VST Connect Pro (VSTCP) and created one from scratch using the instructions in the manual. Now, previously I’ve been able to record both my drummer (using the multitrack feature) and my keyboard player (using midi) without any problems.

Now, for some unknown reason, whenever I play a backing track for them to play to, I hear the backing track instantly, not delayed, which results in me hearing the performer playing out of sync with the track, although in reality the performer is indeed playing in sync, as I can see it visually matching up. I just don’t hear it the way it should be, with the backing track being delayed to compensate. Now as I’ve said before, I’m using the official templates and nothing has changed my end as far as I know, so I really don’t know what’s gone wrong. If I have the ‘To Performer’ channel turned down to zero, as suggested in the instructions, I don’t hear the backing track, so how do i hear it (and in sync with the performer)?

I would be tearing my hair out now, but I haven’t any…

All help is greatly appreciated!

When you say you hear playback immediately without a delay, there are 2 things to check for: a) make sure to not have “Constrain Latency” activated (top left of arrangement window), and b) as ever so often make sure ASIO Guard is off.
When the VST Cuemix plugin is inserted, there must be a delay when you start playback. Other than “Constrain Latency” I wouldn’t know of any other reason why Cubase should not take that plugins’ delay into account.
Speaking of ASIO Guard…this issue that got in the way so often appears to finally be resolved with the upcoming version.
Hope that helps.

Hi Musicullum
thanks for the reply. I’ve checked the two things you suggested and they’re both as they should be - off. I still have the same basic issue: I have my backing track in an audio track, which is then sent to the ‘To Performer’ group channel. The ‘To Performer’ group channel volume is set to zero, so I basically can’t hear the backing track - is that as it should be? If I turn up the volume of the ‘To Performer’ group channel, then I do hear the backing track, but not delayed - is this the reason why the channel should be set to zero? If so, then how do I hear the backing track, delayed to sync with the performer’s playing?

I should just also add while I remember, in the manual for VSTCP it mentions on the ‘setting up the recording in Cubase Nuendo’ page (p7), point #5 says “make sure that monitoring is set to Manual mode”. I really don’t know what this is referring to, as for an audio track, there’s only an on or off state for monitoring, right?

This all worked fine before and now I must have done 8 separate tests with the two aforementioned musicians in different locations with the same problem, which is definitely my end not theirs.

I’m sure there’s something I’m just not doing that is simple to resolve, but the manual is of no help in this regard.

I guess you got this a bit wrong. The idea is to provide an individual headphone mix (“Cue Mix”) to the Performer. The “To Performer” Group Channel carries the VST Connect Cuemix plugin, which sends anything that enters this channel to the Performer. So you should use sends to mix whatever you want the Performer to hear (playback, his own recordings etc) to the “To Performer” channel. Say you have one playback channel, then you want to hear this yourself so you route it to your main output. Additionally, you activate a send to the “To Performer” channel, this way you can provide an individual mix to the Performer.
If instead you set the output of the playback track to the “To Performer” channel, you would have to have the volume of that Group Channel raised because otherwise you will not hear that channel yourself. You can do that but then you can not provide an individual mix to the Performer.
Finally, there is no delay because the delay happens when you hit the start key. It will take a second (if that’s what you set in VST Connects’ Remote Delay setting) before you actually hear playback. This way everything is in sync on both ends.

In the File menu/Preferences there is the VST section where you can set monitoring options. You can set it so that it automatically enables the track monitoring state you mentioned when you engage record (“Tapemachine style”). If this is configured for “Manual” you’re all fine.

I’m not quite sure what your actual problem is, to be honest. You say “I hear the backing track instantly, not delayed” so the question is how do you hear it? Maybe your routing is messed up somehow. When you start transport, is there a delay before you hear playback? There should. Did you try the VST Connect template to start with? If all else fails feel free to send me your Nuendo project (without audio files) so we can check.

Hi again
Yes, I’ll be the first to admit I don’t quite understand the routing of it all, so I hold my hand up and say I’m a bit baffled. That said, I had it working previously so I equally confused why something seems to have changed without my input.

Anyway, I now get what they mean about Monitoring in Manual Mode, and it already is so that’s good.

To address the main point, basically as soon as as I press play/record, I hear the backing track, with no delay, although I can see the transport/locators on the screen are delayed, so it’s the sound that isn’t delayed to match up with the inherent delay from the performers’ side of things, which then results in the backing and performer being out of sync. This wasn’t the case before so I’m unsure what has changed. I can’t rule out that I may have inadvertently changed something though. I have now set up another basic project, using the VST Connect Pro template and uploaded it. Should I send you a link via a PM?

Just one final thing; I found a tutorial on YouTube, that goes through setting up a VST Connect SE session, and to my amazement, it shows that during the recording, the guitar is out of sync with the track, from the engineer’s point of view, but on playback it’s all in sync, exactly the same as my predicament. The odd thing is, the person presenting the tutorial doesn’t even mention (or notice) it was out of sync! Here’s the link to said video;

http://youtu.be/PtA4bdEtZoU

Do you get a message “You can not run 2 Instances of VST Connect Cuemix”? Or any other message?
I don’t quite understand why you have a playback track which is using send to Performer as suggested but another “backing track” which is routed directly to the “To Performer” channel. But it should work nevertheless.
As the Performer is hearing something, the cuemix plug must be active somewhere. Consequently there must be a delay when you start transport. So: Do you have Control Room Mixer enabled? What is your setting for “Remote Delay seconds” in the VST Connect plugin? Finally, what platform(s) are you on, OSX or Windows?
Basically I can find nothing wrong with your project.

No, I haven’t received any message about 2 instances of Cuemix, or any other message.

I wasn’t sure if I should put my backing track into the ‘playback’ track, so I added the additional track in this instance.

The Cuemix is active as per the template I used and is active, and the performer can hear the backing. I can’t however. I can only hear it if I turn up the ‘To Performer’ group channel, which I’m guessing I shouldn’t be doing seeing as the volume is set to zero for a reason. In addition, I can see a delay in the transport, but playback is instant, not delayed.

the remote delay is set to 1 second in the VST connect plugin.

Sorry, I should have reiterated what i said in my original post, but I’m basically running in OSX.

As a last desperate attempt to figure this out, could the issue be with a setting on my I/O device? I’m running Native Instruments Komplete Audio 6 I/O.

Hi Musicullum,
I know you said there’s nothing wrong with my project as far as you can see, but would you be able to create and provide me with a template you know works, so I can see if there are any differences, no matter how small. Appreciate everything you’ve helped with so far, regardless of the outcome.

You already do it with the playback and Performer tracks, using sends to send it to the Performer. If you route it directly, you can’t hear it yourself unless you have Volume up, so that’s ok even if it’s different from the suggestion. So the Performer should hear all those channels, right?

This particular part confuses me. You mean to say that what you hear is not in sync with the readout of the transport bars+beats? That I wouldn’t be able to explain at all (unless you had “Constrain Delay Compensation” on).

I don’t think so. Also your project is just fine, it is obviously derived from the original template so I guess it also makes no sense to send you that as you have it already.
I admit I’m a bit clueless here. Set the “backing” track like the playback track (route to main out, use send to send to “To Performer”) then let me know: beeing connected, when you start transport, sound appears immediately but Transport bar readout is behind? Is Control Room off? Are you definately sure to not have “Constrain Delay Compensation” enabled (it’s a button on the top left of the arrangement Window)?
constrain.jpg

Hi
ok, so I’ve just done another test this morning, and followed everything correctly as I saw it, and I had success. I basically used the simple 4/4 drum pattern I sent you, and asked someone to simply count “1,2,3,4” at the other end whilst I recorded it. Everything was in sync. this was done in my home, with the other person in the same house but on a different network (can’t seem to get the LAN connection option to work). Hopefully the positive result was not simply due to us being in close proximity, as the musicians I need to use are actually on the other side of the world. I’ll hopefully be able to get them to do the test and get the same result. I’ve kept this project so that I can test it with the musicians, knowing it has previously worked.

going back to your last set of questions;

• yes, the musicians can hear everything that I need to play to them.

• Previously, whenever I’ve played the backing track to the musicians, I hear instant playback of the audio (backing track) but the visual side of it is delayed, so the transport is behind what I hear, but is probably in sync with what the musician hears. 'Constrain Delay Compensation’has always been grey, as opposed to orange, so I guess that means it’s in the off position.

• I don’t use Control Room, so that is also off.

I think you’ve done more than enough to help, so all I’ll do now is once I’ve had a chance to do a real world test (i.e. a session/performer that’s not 10 metres away from me), then I’ll report back on my findings if that’s ok.

Hopefully the upcoming update to VST C Pro will improve things further, but so far we’ve experienced lots of crashes and dropouts, even putting to one side the issue we’ve discussed here. I really want it to work though, so I’m just glad it exists!

Thanks again.

Great!

If you are on the same (local) network (means connected to the same router), there is a green button in the Performer, provided a Cubase/Nuendo with an activated VST Connect plugin has been started before. Click it and select the item shown. This always works unless you have a very uncommon network setup.

The technology doesn’t care at all about how far the other peer is. You may well have a better connection to somebody far away than someone almost next door but with less connection quality.

You said previously…so that mysterious lagging of display is gone now?

You’re welcome. We don’t get crash reports other than when external plugins are involved. And because we also want this to be rock steady, pls let us know under what circumstances you have crashes so we can fix it. Finally yes, we’re close to releasing a new version whith some improvements, seems we even solved that dreadful ASIO Guard issue.
Stay tuned :slight_smile:

Hi
the arrangement started with a delay, which I think it is supposed to do from what it says in the manual, but when it played it was in sync with the audio backing I was hearing, so it was all good. The only side issue that now bugs me is that I wanted to try the test again, with the same person, using the method I mentioned, but this time with midi, but bizarrely, VST Connect Performer decided to stop working on the other person’s laptop. Even when rebooting, VSTC Performer just became unresponsive - he’s using a MacBook Pro. I’ll reinstall and hopefully I’ll be able to test again. Thanks for your help, it’s always appreciated.

Just a quick update to this subject; I have now managed to test VST Connect Pro with a performer in the UK (I’m in Taiwan), via MIDI. Everything was a success, so now I’ve been able to test both audio & midi scenarios, I’m quite confident in continuing with recording again.

The only issue that remains - but one with with I can work around for now - is that if I want to get a few ‘takes’ from a performer, and have a section of the backing track looped, every time it approaches the end of the loop, there’s an audio dropout on both the initial lo-res recording (it doesn’t seem to be there when I download the HD files). In the case of a MIDI recording using the same scenario, when it approaches the point of looping to the beginning of the loop, the track goes out of sync, the subsequent MIDI ‘takes’ end up out of sync. I can work around this for now, but I’m not sure if anyone else has experienced this or there’s something I need to activate in the case of recording in looped mode.

Sorry, looping (playing in cycle mode) is not (yet) supported entirely by VST Connect. Create repeated events to ‘simulate’ a loop.
Good to know that it all finally worked out for you, thanks for your patience!

Hi
glad to know it’s not an issue for me alone regarding looping/cycle mode.

And finally, thank YOU for YOUR patience!