Audio timing issue in Cubase 13 Artist

Help Please. When I try to record an outboard instrument (eg MicroKorg) being controlled by a MIDI track I get a timing issue. The audio actually sounds ahead of the MIDI. Can anyone suggest how I can overcome this issue.

Hi,

Are you on Mac or Windows, please? If you are on Windows, what kind of MIDI Driver type do you use? Could you attach the Studio > Studio Setup > MIDI Ports Setup window screenshot?

You can try to toggle the ASIO Latency Compensation on the MIDI track.
grafik
NB: You might have to make this button visible first. Right click the track and choose “track control settings” to set it up.

In “Studio Setp → Audio System” you can toggle the option for “Adjust for Record Latency” and/or change the value for “Record Shift”. You’d have to measure the amount of samples first, of course.
grafik

Thanks very much. Haven’t used my maths skills for a long time but you suggestion seems to have worked.

Thanks for your suggestion.