Audio units with older/lower spec iPads

Hello - has anyone had success using audio units (AUv3) with older or lower spec iPads? I have a 6th generation (around 2018) standard iPad, which has been fine until I tried using third party piano units. I’ve tried three and all give clicky/distorted sound (and sometimes cutout completely). 'Just wondering if there is a fix or better combination before I give up and just revert back to Microsonic. Thanks! (For info I have tried G. Piano AUv3, Ravenscroft 275, and one of the cheaper/smaller Colossus pianos.)
Geoff D.

On the Play page of Preferences there’s an option for multi-core processing: try switching that off.

That’s made a massive difference thanks Daniel. Now G. Piano AUv3 seems fine, the Colossus also fine, but can be temperamental over whether it starts up (incidentally it is the Japanese Grand that I have from the Colossus stable). The Ravenscroft is still a bit clicky, but miles better than before.
Thanks again!
(For info in case useful to anyone - if the Japanese Grand does not start playing, switching the sound to, eg, “Japanese Grand with Pad” and back seems to fix it.)

One final word on this from me in case of any use/interest to anyone. Today (with Daniel’s suggestion) the Ravenscroft 275 seems to be playing back perfectly (to my ear) on my older iPad. No idea what has changed today, but I will be sticking with the Ravenscroft 275 as much as I can get away with it.