Audio & VSTi out of sync on export to mixdown.

Here’s what I want to do:

  • Using a couple of drum VST instruments like Battery or Superior Drummer I want to record several instrument tracks of drums and percussion.

  • Now I want to export/mixdown one of those tracks to an audio track and leave the rest as
    unmixed-down/unexported instrument tracks

  • I want to hit playback and have the unmixed-down/unexported VST instrument tracks play in perfect sync with the one I mixed-down/exported to an audio track.

    FWIW, I’ve read a lot of posts that seem to indicate this is inherent in the use of VST instruments and effects and the solution is to manually “nudge” the audio or midi (can’t remember which) but I can’t imagine in my wildest dreams this is actually the solution and there’s not a setting in Cubase to compensate for this. Using record shift would imply that I’ll have to use a different setting everytime I change buffer sizes, sample rates, and possibly VST instruments depending on their particular latencies.

I selected “Boost” but I can still hear that the audio and unfrozen Superior Drummer VSTi track are out of sync. I figured I’d do a null test between the unfrozen instrument and a mixdown of said VSTi but only after the following (which only serves to confuse the issue for me):

I’ve done a null test of the frozen instrument track and an exported mixdown of the frozen track which confuses me even more. The frozen track insures no round robin issues can occur when comparing it with the mixed down audio track so the mixed down audio should be sonically identical. Since the frozen instrument track is actually a cached audio track it should be subject to the same delay as the mixed down audio track.

I’m so confused.