Audioverbindungen bei Gerätewechsel weg?

Tach auch!

Ich starte meine Audiointerfaces immer manuell (Motu 828es + Anhang)
und wenn ichs mal vergesse und Cubase starte, kommt recht häufig vor :(,
sind die Audiogeräte unter Audioverbindungen nicht mehr verbunden.

Seeeeehr nervig.

Gibt´s da eine Lösung oder nur lernen durch Schmerz?

Wieso speichert Cubase die Verbindungen nicht je nachdem welches Audiogerät ausgewählt ist?

Bug oder “Feature”?

Welche Cubase-Version hast Du?
Ich vergesse auch manchmal, mein Interface einzuschalten, dann kommt aber eine Meldung beim Start von Cubase 11 pro:
image
Wenn ich vor dem OK das Interface einschalte, ist anschließend alles in Ordnung und alle Verbindungen bleiben erhalten.

1 Like

Moin!

Danke für den Tipp. Ja, ich arbeite auch mit Cubase 11 pro und habe es gerade probiert
und es hat leider nicht funktioniert.

Ich habe Cubase gestartet bis zu deinem geposteten Fenster, dann habe ich meine
Audiointerfaces gestartet bis alles initialisiert wurde und habe dann das Motu Interface
in dem grauen Fenster ausgewählt und Ok gedrückt und nun sind sämtliche Verbindungen weg.

Ok, also für mich wohl lernen durch Schmerz. Aber was ist mit jenen, die ein Notebook wie nen Apple M1 MBP
als DAW nutzen? UNterwegs mit kleinem INterface und im Studio ein großes AVB Netzwerk?
Bin momentan noch unter Windows 10

Ist das jetzt ein Bug oder einfach nur eine schlechte Programmierung?

Hast Du Deine wichtigsten Ein- und Ausgangseinstellungen als Presets gespeichert? Die kannst Du dann schnell wieder zurück holen.

1 Like

Das habe ich auch schon probiert.

Also alles eingerichtet → Als Preset gespeichert, Preset dupliziert.

Zum testen: Interface aus, Cubase gestartet (ALle Verbindungen weg),
dann nochmal gestartet mit angeschaltetem Interface, das entsprechende
Preset geladen, Cubase neugestartet → Alle Verbindungen immer noch weg.

Funktioniert bei mir nicht.

Könnte es sein, dass ich hier ein anderes Problem habe, was evtl mit Windows zu tun hat?

Vielleicht hatte ich Dich eingangs falsch verstanden.
Bei mir erscheint in den Audioverbindungen nach JEDEM Start generell nur ein Stereo-Paar bei den Ein- und Ausgängen, aber natürlich mit dem zurzeit angeschlossenen Interface (habe mehrere zur Auswahl).
Wenn ich ein Projekt bei Null (leere oder von Steinberg mitgelieferte Vorlage) beginne, muss ich erstmal passende Presets für die Ein- und Ausgangskonfiguration laden oder die Audioverbindungen manuell konfigurieren.
Das ist bei mir aber schon lange so und hat nichts damit zu tun, ob ich vergessen hatte, das Interface vor dem Cubase-Start einzuschalten.
image

ABER: Wenn ich dagegen eine selbst erstellte Projektvorlage lade, sind darin auch die dazu passenden Audioverbindungen mit enthalten.

1 Like

Bei mir ändert sich da nichts, wenn ich ein Projekt lade.
Für die Ein- Ausgänge und dem Controlroom kann ich zwar die Presets laden,
aber davon bleiben die externen Effekt- und Instrumentenwege unbeeindruckt.

Sie sind zwar da, aber nicht im Audioweg verbunden und wenn ich das Audiogerät auswählen,
dann sind auch nicht die zuvor konfigurierten Ein- bzw AUsgänge ausgewählt, das muss ich
dann jedesmal manuell machen.

Ich kann mir nur schwer vorstellen, dass das so sein soll und vermute eher einen Fehler,
evtl Einstellungssache? Und wenn das so sein soll, verstehe ich den Sinn dahinter nicht,
was man sich dabei gedacht haben soll.

Habe mal mit einem Hex-Editor in eine cpr-Projektvorlage geschaut.
Die Audioverbindungen sind dort eingetragen!
image

Das müsste eigentlich auch bei Dir so sein.

Erstelle mal ein leeres Projekt, konfiguriere die Audioverbindungen und speichere das Ganze als leere Vorlage “test” ab. Dann schließe Cubase, starte es neu und lade diese Vorlage. Audioverbindungen wieder weg??

Gerade probiert. Sobald ich Cubase einmal mit deaktiviertem AudioInterface gestartet habe,
sind die Verbindungen futsch und selbst wenn ich das Audiointerface starte, werden die Verbindungen nicht hergestellt.

Also die Konfiguration der Busse sind schon da, es sind nur keine Geräte verbunden, auch der Controllroom hat keine Verbindung

Gibt nur eine Einstellung diesbzgl.

UNter Programmeinstellungen → VST
Eingangs-/Ausgangsbusse beim Laden externer Projekte nicht verbinden.

Aber das ist nicht aktiviert.

Kannst Du mal einen Screenshot posten, wie die Audioverbindungen Dir vor- und nachher aussehen?
Die Studioeinstellungen sind in beiden Fällen unverändert?
Bei mir z.B.
image

Diese Option gilt je eigentlich nur für Projekte, die auf anderen Systemen erstellt wurden.

Schau auch mal in Deinen Benutzereinstellungs-Ordner. Da gibt es eine Datei Port Setup.xml, in der alle angeschlossenen MIDI- und Audio-Hardwaregeräte eingetragen sind. Schau mal nach, ob da Dein Motu-Interface eingetragen ist (evtl. mehrfach?)

Danke nochmal vielmals, dass du dich meinem Problem annimmst.

Die Studioeinstellungen sind nicht betroffen, nur die Verbindungen. Hier die Screenshots
und mir graut es schon davor alles wieder einstellen zu müssen.


Step2_Treiber+Interfacestart

Bei Bild 2 habe ich das Interface gestartet und es ist auch vollständig initialisiert und
ich kann bei Bild 3 dann auch die Verbindungen wieder einstellen

1 Like

Externe Instrumente nutze ich schon einige Zeit nicht mehr (eigentlich nur noch live), so dass ich bisher noch nicht getestet habe, wie das in dem Fall mit den Einstellungen aussieht. Aber eigentlich müssten die Verbindungen doch auch in der cpr-Datei mit gespeichert sein. Ich werde es später aus Neugier mal testen.

Edit:
Hab jetzt mal den Test gemacht.
Ein externes Instrument eingerichtet (erst als MIDI-Gerät, dann die Audioverbindungen eingestellt).

Dann Cubase geschlossen und wieder geöffnet - zunächst ohne Projekt.
Die Ein- und Ausgangsverbindungen zeigen wie gewohnt nur je einen Stereo-Kanal, aber das externe Instrument ist da, wie im Bild oben.

Danach habe ich das Interface ausgeschaltet und Cubase neu gestartet, es erscheint das Fenster “Audiotreiber-Einstellungen”.
Nach dem Einschalten des Interface und ohne ein Projekt zu laden ist auch bei mir in den Audioeinstellungen zwar das externe Instrument noch vorhanden, aber ohne Verbindung zum Audiointerface:


Auch die Audioeingänge sind nicht verbunden, während die Audioausgänge die Verbindung nicht verloren haben.

Wenn ich danach eine Projektvorlage öffne, sind alle Eingangs- und Ausgangsverbindungen wieder da, wie gespeichert. Bei den externen Instrumenten sind die Geräteports jedoch nicht verbunden, ich muss sie manuell neu einrichten.

Ergebnis der ganzen Untersuchungen:
Das von Dir beschriebene Verhalten scheint ein allgemeines Problem zu sein.
Um Steinberg darauf aufmerksam zu machen, sollte es als Issue im englischen Forum gepostet werden.

1 Like

Nein, werden nicht gespeichert. Der Controlroom usw ist ja auch weg.

siehe Edit oben

Danke für die Mühe.

Ich werde einfach den Suppport anschreiben mit Verweis auf dieses Thema.

Im Projekt bzw. der Vorlage sind die Audioverbindungen zum externen Instrument schon gespeichert, aber sie werden beim Laden offensichtlich nicht berücksichtigt.
image

Hallo @Global_Zone , im englischen Forum gibt es aktuell einen ähnlichen Fall, dort wurde von @ColdSteel ein Workaround vorgeschlagen (Thx!), den Du evtl. auch mal testen könntest:

External instruments “forget” their assigned connections if audio-interface is disconnected - Cubase - Steinberg Forums

Ich vermute hier nur (werde dies so schnell wie möglich testen), aber eine Lösung könnte darin bestehen, alles richtig einzurichten, Cubase zu schließen und dann die Datei „External Plugins.xml“ zu sichern. Und wenn ich versehentlich etwas durcheinander bringe, indem ich eine Schnittstelle trenne, kann ich Cubase schließen und die External Plugins.xml wiederherstellen und dann sollte hoffentlich alles wieder normal sein.

2 Likes

Danke für den Hinweis und es funktioniert!

Ich habe einfach die funktionierende “External Plugins.xml” im gleichen Ordner kopiert,
sodass ich eine -kopie habe und die funktionierende zusätzlich noch schreibgeschützt.

1 Like