Augmentation dot and tie collision

I’ve played with the Engraving Options extensively but I can’t find a way to prevent this particular collision. The other settings are fine, including starting a tie before the dots. In most cases Dorico’s vertical adjustment to avoid tie collisions with dots works well but in the case of this chord the tie needs to be moved horizontally to start after the dot. I know I can move in in Engrave Mode but is there a setting which would do this globally?

augmentation dot and tie collision.png

I’ve literally never experienced something like this, as the tie spacing algorithms seem to always account for dots and avoid them automatically.

Is there something else going on here perhaps? Manual adjustment in this case shouldn’t be necessary.

That’ll be your problem right there! :laughing:

This is what I get without any effort, so you may have adjusted something. There’s a section in Engraving Options > Ties > Avoiding Collision, which relates to dotted notes.

I get similar collisions with dots importing a XML file made in Finale.

In File / Preferences / MusicXML Import, try switching off “tie placement and appearance” to let Dorico reformat them.

If that doesn’t help, select everything and do Edit / Reset Appearance and Edit / Reset Position.

I haven’t imported this. Unfortunately I can’t reset the tie settings without resetting all my other settings as well, which will wreak havoc with all sorts of things, especially layout. Resetting the appearance or position simply uses the Engraving Options settings.

  1. Open one of the Example projects (/Users/Shared/Dorico Example Projects) and compare the Engraving Options with your projects. You can have the Engraving Options for two projects open at the same time, if you have window space (or two monitors).

  2. There are different files for each of the ‘Options’: Engraving, Layout, Notation, Playback, as well as preferences and userdefaults. So you don’t have to reset everything. You could at least restart Dorico after removing the Engraving Options file, and then reset the document to the new defaults, and see if that improves things, and what needs to be re-set to your liking.

  3. Or just try mucking about with the Tie options.