AutoLFO on MIDI track only works when VST track selected

Hi there,

I followed vic_france’s instructions (http://www.steinberg.net/forums/viewtopic.php?p=431585) to use an autoLFO inserted on a MIDI channel using MIDI loopback to control quick control parameters in a VST (ABL for what it’s worth).

It’s working fine when the VST track is selected, however when I select a different track, the autoLFOs do not control any longer the parameters. It must be something simple but I just can’t find the setting.

Thanks for any help.

Cheers,

do you have the ‘monitor’ button(s) on?

Hi, thanks for getting back. Yes, I tried with monitor buttons on (on 2 MIDI tracks with autolfos inserted plus the instrument track) and off. No difference.

Thanks.

I am noticing the same problem, but my reasons for using MIDI loopback routed to Quick Control has nothing to do with AutoLFO (I use it to translate momentary switches on MIDI controller into increment/decrement MIDI Modifier->Transpose Quick Controls on drum MIDI tracks, as this is not in generic remote). To be fair, I’m relatively new to Cubase, so as a learning opportunity I’ve been playing around with this for days now. It seems as though MIDI CC information is only active thru to the selected MIDI track (or most recently selected MIDI track, if multiple MIDI tracks are selected). Even while successfully recording note on/off events on multiple MIDI tracks, MIDI CC changes are only recorded on the track last selected. Is this intended functionality? If so, is there a setting to enable CC thru for MIDI tracks that are monitor enabled or record enabled but not selected?

Thanks,
doggy

(I think I proposed two alternative methods?)…
If you are using the Remote Devices>Generic Remote method, the incoming Auto LFO (from the loopback) will always go to the currently-selected track (where the lower line says “Selected” :wink: ). You can change this to the actual MIDI/Instrument track (you should see the track name in the dropdown list)… in which case it will always control just that track, whether selected or not.
Unfortunately, if you are using the simpler Remote Devices>Track Quick Controls method, then it will only work on the Quick Controls for the currently-selected track. (and let’s be honest, we’re already pushing the boat out pretty far, to get it to do even that! :wink: )

@doggieaugie
If, as you say, you are fairly new to Cubase, then you are already being very adventurous… bravo! :slight_smile:
So… have a go at adapting your loopback, to use a Generic Remote instead ( if you haven’t already done so, take a look at the link posted earlier by truest…it is a bit more complicated, but you’ll have earned your badge of merit :wink: )

Yes, it works! I had thought that since the MIDI Modifier Transpose parameter was not available in Generic Remote Device routing, I had to route a MIDI CC using Track Quick Control Remote. I did not know that you can simply control Track Quick Control parameters through Generic Remote!

Thanks so much! (and vic_france, for what it’s worth, I did in fact read the link above containing your tutorial before posting.)

doggy