Automap problem

I bought a SLMkII about two months ago and I’ve been having this frustrating problem ever since which I can’t figure out.

When I launch Cubase (6.05 x64), Automap simply do not automatically map any of the sliders/pots/keys/whatever in the mixer section. I have to map every single one of them manually. Every VST plugin I have is mapped correctly when their corresponding map is automatically loaded, and the transport section on the SL MkII works as it should: stop/start/record/ff/etc.

But not the mixer. I’ve posted this on Novation’s forum but haven’t received a reply. Novation support didn’t see anything out of the ordinary when I sent them a screenshot of the midi setup page in Cubase, nor did the default Cubase mixer map they emailed me, make any difference.

I have been through the setup routine several times, uinstalled and reinstalled Automap, updated to the latest 4.2b version of Automap - I even flashed the SL MkII with the latest ROM update (which it already had) just so it would be reset back to factory settings in case that was the problem. Cubase and Automap are running as administrator, but I notice that Automap is x32, so could the problem lie there?

I am completely stumped at the moment and starting to wonder if there’s a setting in Cubase that’s disabled or something, but I don’t know where to look.

Can anybody please help me out?

This is maybe too obvious, but … after you set up the mixer, do you make sure you go to the File menu and click ‘Set as default for this device?’

I recall installing the control map for Cubase before, and having it work fine.


I was finally able to get the mixer map working, after spending two hours trying different things (that’s excluding all the time I spent in the past two months, by the way).

I removed the software again, any settings in Cubase (including the Novation Automap device), every SL MkII related stuff I could find in the registry. I also deleted any Novation/FocusRite folder I could find.

After reinstallation of 4.2b2 I noticed that it still loaded my custom mixer map. Here’s the thing; I mapped insert instrument track and edit instrument to unused mixer buttons in order to have easily accessible shortcuts. Then I clicked set default in Automap.

I removed Automap again (same steps as before, registry and all), but this time I searched the entire drive for *.automap and deleted everything I could find.

After reinstallation - what do you know - every new track was auto mapped. It did not load the old custom map anymore.

I’ve been trying various things, and I believe I’ve either stumbled upon a bug or something the programmers didn’t think of, or I have a broken DAW.

Now if anyone else can please try this:
Load Cubase and add a new track, and this new track should be auto mapped.
Save this map (do NOT set as default!), hit revert and then load the map you just saved.

The tracks you already have should be working as normal, but any new track you create will not be auto mapped.
If you hit revert, everything should work as before.

You can even save an unassigned map, if you open that map and insert a track, it still shouldn’t auto map anything to the controller.

Can anyone else confirm this?