Automation is not shown

I have a VST track. I assigned a MIDI slide control (CC 72) to a feature on the VST, and recorded the automation. It plays back correctly, so the automation is there. But when I show that automation track, I see a straight line, when I should be seeing a line with changes, you know, hills and valleys, if you will. Kind of makes it difficult to tweak what you can’t see. How do I get the recorded automation to show?

Hi,

What automation do you show? The MIDI CC, or the parameter? Did you try to Show Used Automation function?

The MIDI CC, and yes, Show Used Automation (Selected Tracks).

The only one it will show is Volume. Also, this only happens if I hide the automation track, then try to show it again later.

This is the track and the results of Show Used Automation (Selected Tracks), when the track in question is selected:
CubaseCapture.png

Isn’t the CC72 written in the track, then?

Maybe. But if so, the only place I can reach them is in the Key Editor, and they are more difficult to edit there. And I’ve got other Kontakt MIDI tracks using the same trick, and their automation tracks show under their main track. I won’t hide them, because I fear I won’t be able to get them to show again, especially if I save the project and come back to it later.

Use the Midi/Functions/Extract Midi Automation command to flip controller lane data to track automation.

Or you can Record even MIDI Controllers immediately as an Automation track.

Thank you! That brought it back out. That leaves me wondering how/why it got rolled into the track in the first place. Does hiding an automation track do this?

I think that’s what I did. In the Kontakt instrument, I linked a slide control on my MIDI controller to a slider in the instrument, activated the Write Automation on the track, and recorded it all as I played and moved the slider. The automation track was visible, I could see the movement. It all disappeared when I hid the automation track and then tried to show it again in a later session.

I have an “Automation Not Shown” issue, but it has to do with Automation Values not being shown for, in this case, the Chopper’s Speed Control.

In my tracks, I am Able to Record and playback different values for the Choppers “Speed” via settings on the Effect’s dial. However, I’d like the simplicity and accuracy of entering the values directly on the Automation Lane. However, if I try to Insert a new Automation Point and drag it up and down it has no effect on the Length dial of the Chopper. I have tried keeping Read and Write Enabled and just Read Enabled, but the points seem to be holding to the last used value creating during automation generated as the track is rolling and recording.

In my screen shot the three Automation Points circled in Red all have the same value, and, even if I move those points up or down, the value remains. Hence, I can’t seem to record new Speed values at the points I want them?
Chopper Automation.png
There are distinct steps for Chopper’s Speed Control, I want to be able to Jump from one to another at exact times. Same for any and all other plug-in.

Thanks for any help on this.

Hi,

Did you assign the MIDI CC to the parameter in Cubase (like Quick Controls or Generic Remote Device) or in Kontakt.

Hi,

If I got you right… In this case the plug-in shows the vlaue which is at the cursor position. If you please cour cursor to the Automation Node, then you should see the Value change in the plug-in.

Hi, Martin. I assigned it in Kontakt, since it was a function in the Kontakt instrument and that’s what I’m used to doing. Is there a way to do that in Cubase that works better?

Hi,

If I got you right… In this case the plug-in shows the vlaue which is at the cursor position. If you please cour cursor to the Automation Node, then you should see the Value change in the plug-in.[/quote]

I posted about this possible bug here: https://www.steinberg.net/forums/viewtopic.php?f=250&t=111349#p609682

I’ve tested a few of the Cubase Plugins, but not all. It seems some respond as they should, others seem buggy in how they display recorded automation of synch controls. Yes, the value is displayed at the cursor and that was a good workaround, but the I feel the issue, or my question, is still open. I need to learn to use the animated GIF files to show this better.

Thanks for your help on this.

Hi,

In this case, the automation of the target parameter is not written. Only the MIDI CC is written while record. And later on the parameter is again reading the values by MIDI Learn.