Automation not rendering as I moved fader.


I’m doing some vocal rides with the cc121 and Cubase 9.
I’m trying to automate phrases or add sustain to notes.
Initially Cubase records my volume rides accurately in the automation lane. Then after I let go of the fader (in touch mode)
It renders the line with much less detail , sometimes I lose completely what I was trying to do., ie the line is almost rendered flat again.

Is there any way I can get Cubase to keep the detail, or most of it , from the fader rides??

Thanks !

Automation panel (F6), settings. You can set the reduction factor there.

Thank you!
Yes , it must have been seeing the jump rides as spikes.
Lowering the numbers makes it work like I want.