Automation resolution, question 2

I have changes the setting to make automation “resolution” bigger.

Why my automation still are so gnarled?

I expected it to be more smooth. Cuz now, for example, filters are jumping and I don’t feel gradual changes of values but noticable jumps all around (EQ, filters, gain).

Automation is not midi.

Well, that option helped me here: https://www.steinberg.net/forums/viewtopic.php?f=250&t=118746

So, how to make automation more accurate, please?

Automation panel/settings/reduction level