Autoplay causing stuttering of decoded MP2 file

I have a project whereby I have extracted the audio from a video file, resulting in a 48kHz MP2. I notice that when Auto-Play Mode is on, if I then drag the file into the editor, decoding occurs, but the resulting file has glitches.

Yes, the solution is trivial (“don’t do that”), but would it not be better for the application to stop playback of the file if it is being opened for editing?

I assume the issue is that two processes are competing to read the file – the audio preview and the decoding process – but surely the decoder should have absolute priority? Of course, it may be just my setup, but if it’s a general problem it is worrying because the integrity of the file in the editor is affected. The glitches are not obvious either … you’ve got to listen through to detect them, so in the case of a quick edit of just one region of the file you could easily miss them, assuming that the entire decoding process was without error (as is usually the case).

Can anyone confirm this? As a test, select an MP2 or MP3 file in the (WL7) File Browser with Auto-Play switched on, drag the file into the editor and then check for glitches.

Actually I don’t understand why this is possible, as file decoding is not constrained by time.
How large is the file, so that I can try to reproduce?

The file is 59.2MB in size, MP2-encoded 128kbps 2-channel (stereo), 48kHz, 1 hour long.

It’s possible the file has some issues as it is an .mp2 file recovered from a .ts container file which was a radio program recorded using a DVB-T2 receiver. I’ll try to reproduce it with another file. On the other hand, if I stop Auto-play before dragging into the editor it decodes perfectly.

OK I’ve been able to reproduce this with a 30s segment which I’ve uploaded.

  1. Turn on Auto-play in the WL7 file browser
  2. In the file browser, locate the file WL7_test_source.mp2 (attached)
  3. Click on it; the file starts to play via Auto-play
  4. While the file is playing, drag into the editor
    (At this point I hear garbled audio while the file is being decoded)
  5. Stop playback in the file browser
  6. Play the file in the editor; I hear periodic glitches (~3s) as in “WL7_test_glitches.mp2” which I created by simply doing a “Save As …” from the editor.

The problem does not happen if I stop playback before I drag the file into the editor. N.B. the temporary file has to be cleared from the WL7 cache folder in order to force a new decoding and load it cleanly. (517 KB) (626 KB)

Thanks for the accurate report. I will try to reproduce in the coming days.