Autosave NOT WORKING properly FOR YEARS!

My Cubase 10.5 just crashed. Ok, it happens sometimes, some 3rd party plugins, for example…

My Autosave interval is set to 3.0 min with maximum of 15 backups.
The crash happened at 17.04.
The latest Backup file I found is at 16.57
the ones before it - 16.37 16.34 16.29 and so on with random intervals up to 10 minutes long…

Can anyone explain, please, how is that possible?
I didn’t close the project, I didn’t change the system time… I was only working on my project, and all those tiny precious tweaks of the latest few minutes (as usually) are now lost because Cubase did not autosave properly.

Why do we need this option, if it never works properly FOR YEARS, since I was using Cubase 7.0 (at least) ??

  • before writing this post, I recovered my project, saved it under the new name at 17.20
    Then I unchecked and checked again the Auto Save in Preferences and set the interval to 2,9 min.
    It’s 17.28 now - do you know how many backups were made? - NONE

The cause is because Autosave will not save while a Project is playing. So if you are using loop playback for 20 minutes then there will be 20 minutes between saves. If you pause playback then the next autosave will occur. So it is a good idea to get in the habit of pausing playback every so often to give Autosave an opportunity to execute.

Warning beyond here lies PURE SPECULATION
If while playing you manually Save the Project it will indeed save. I suspect the problem with Autosave during playback is that in addition to actually saving the Project data it also needs to create a brand new file for every Autosave and this additional task messes up the playback.

Thanks! That explains something.
But actually I don’t do such long playbacks.
Ok, I’ll do some tests and try to notice how the autosave behaves

Interesting thoughts Raino.

I wonder if there is some ancient coding behind all this from when there was performance issues on computers - these days auto saving a project whilst it is playing should not be an issue…!

If auto-save is prevented from saving while a project is saving, how come you can save your current project, and even do a save as - which calls up a file dialogue box and produces a completely new file, whilst still playing back? Doesn’t make any sense.

Also, and this comes from nearly 30 years of using Cubase, there is simply no consistency to auto-save working. I have some projects it works perfectly OK on, and others that it simply refuses to do so. I can assure you that there is always a period of time when I am not playing back a particular project when auto-save could kick in, but doesn’t!

Same on my machine… I’ve projects where the autosave function works perfectly, some projects save only every couple hours and some rare projects won’t autosave at all. Till now I couldn’t figure out whats the reason for this behavior.

Sorry but this is not true at all: my old Cubase Pro v5.5.3 from 10 yrs ago did save any project without any problem regardless if it was playing or not. There definitely seems to be something in play.

What I would try would be this:

  • before you start Cubase, copy and paste your project file (*.cpr) that doe snot autosave despite you set it in preferences and change its extension from .cpr to .bak manually
  • now open your project, check once again in settings that autosave feature is on and let it stay like that for lets say 20 minutes or even for more at this 1st time
  • now look inside the folder with your project if there was created new file with .bak extension

To meit looks like for some reason sometimes Cubase is unable creating that file autmatically by itself, but once the first .bat is there it continue creating new ones every time it has to, like evry 15 minutes (depending on what time you set in the autosave preferencies).

if that doe snot help, then it really is something weird with the Cubase, I would try to place your project temporarily in some very short path, like directly to C:\your-project, and I would make temporarily the project name one word (you knoe, so there would be no spaces - you never know what it is that Cubase doe snot like)…good luck!