Auxiliary instrument won't show in Engrave mode unless doubled

In my current score, one player has been allocated Clarinet 3, Alto Clarinet in Eb, and Bass Clarinet. I noticed that an Eb Cl. passage which I’d just input didn’t show in Engrave mode. If I experimentally copied it to Cl. 2, both showed (see image), but - if I copied it to any other instrument - only the destination stave displayed the passage.
Wondering whether this was a multi-instrument player issue, I cut the passage from the Eb clarinet and pasted it into the Alto Flute stave (which is shared with Flute 2), and it was correctly shown in Engrave mode. [Later] I now see that a subsequent passage I’ve copied from Eb Cl. to Piccolo shows the music on the Piccolo stave only.
I have evidently made some kind of error in Setup, but what might it be?

I think if you can share a cut-down version of the project that includes these bars, that will be the easiest way for people to look at the specifics and make some suggestions.

Here it is. I’ve added the problem details to the score itself, including my realisation that the passages in question don’t appear in Page view either, only in Galley. This makes me think that I must have accidentally invoked some kind of ‘hide staves’ command, but I can’t figure it out. (During the few months since I last used the program, I’ve forgotten a lot of what I’d learnt about Dorico, I must admit.)
Symffoni - 3rd movement.dorico (700.4 KB)


In Dorico 3.5 only the first instrument of a solo player holding multiple instruments is consider for condensing. Condensing problem: secondary instruments not condensable - #2 by pianoleo In your score that would be the 3rd B flat clarinet, and the other instrument(s) should appear on a separate staff. I guess the problem here is that none of the others instruments of the condensing group (clarinets) has anything written in those bars. However you can insert a condensing change at the beginning of the system (or togheter with a system brake if needed). In the condensing Change Dialog select the Clarinets group, and in condensing approach select “no condensing”. That should force the E flat clarinet to show in the score.

I hope that helps.

1 Like

It helps a great deal, Rafael, thanks. I have to admit not ever having clocked the condensing limitation, and your explanation of manual condensing is greatly appreciated.

As a general rule it’s inadvisable to turn on condensing until you have input all your notes. Not only can notes disappear (as you discovered) but, in large scores, it can slow down your machine.

Thanks, Janus. As a matter of fact, I didn’t realise condensing was on until I needed to do an operation in Engrave Mode - and indeed I only realised that the passages in question were ‘missing’ in Page View until I happened (after my initial post on this) to switch to that view (I work entirely in Galley View when inputting).

But at least I now know of the care needed in using the condensing feature, and am busy getting to grips with how to deal with the doubling and multi-instrument players in my score. I’ve already excluded my clarinet group from condensing, and have now discovered the excellent ‘creating custom condensing groups’ which has allowed me to condense my 1st and 2nd clarinets. Thanks all!