AVID Eucon incompatibility CUBASE 8.5

I receive the request to downlaod the adaptor when on the panel of the device manager I try to add (+) the “Eucon” that it stays with a red (!).
I found a 64bit Cubase 6.0.5 adaptor, but didn’t change anything.
The Avid eucon software at the start of Windows 7 Pro says that all is fine.
I tried also uninstalling the Avid bundle software and reinstalling only the adaptor.

Anybody solved this before?
I’m in wait of official support.
Thank you!

I have the same issue in 8.5.15. I am trying to get my Avid System 5 console to connect to Cubase via Eucon. For now I am back to Pro Tools HDx.

No valid EuCon software can be found on the system when trying to add EuCon from Device Setup.

@ Carmelo,

I don’t see any of your spec’s, so it’s hard to track your problem down…

I will say that Cubase now requires the latest version of EuControl which you can download from AVID.

That adapter you found is for an earlier version of Cubase, and should not be used (de-installed) if you are using a current version of Cubase!

The current adapter is included as part of the Cubase 8 installer, and is not set to install by default, so it must be explicitly ticked to install during installation.

@ R,
I’m not certain about the System 5, but you may be having a similar problem if you are not running the current version of EuControl with the current version of Cubase, or you also have not ticked the EuCon Adapter to install during the Cubase 8 installation.

The answer to both of these scenario’s are to re-run the Cubase 8 installer, but just install the EuCon Adapter, and install the latest version of EuControl from AVID!


I ran Cubase Pro 8.0 installer again but there is no Eucon to install.

Are you running Cubase 8 64bit? I’m sure you already know EuCon is now only supported on 64bit systems!

That said… I just re-ran the Cubase 8.0 installer myself, and I also did not see the option to install the EuCon Adapter!
So, my bad for leading you astray! :blush:

This was the way the Cubase 7 installer handled the EuCon Adapter… I promise!

The " No Valid EuCon Installed" prompt usually happens when Cubase can’t find a current version of EuControl on your system!

What version of EuControl do you have? As I’ve said above… I’m not familiar with the system 5, so I’m not sure if it uses the same version that the Artist Series devices use.

Just looking at the AVID site… there seems to be quite a few people having issues with that unit!

I can say that my Artist Series Devices are working with Cubase 8.5.15



I found a solution for Mac:

Proof the Cubase app with right click and go to “information”. Untick the 32-Bit mode if activated. Eucon only runs in 64-Bit Mode.