Avoid half bar splits due to sorting out accidentals spacing

Hello and greetings to the Dorico team and to you all.

My Q. today is, I am using clusters and thus accidentals tends to sometimes clutter the previous chord. ( it would have been lovely if it wouldn’t…).
I have used the ctrl+shft+e which certainly aid a bit but resetting shortest note value caused bars to halfway split… ( I have so chosen note to use the “optical” option), I still didn’t get the accidentals right. I’d have liked to increase space for shorter notes without having a bar to halfway split, I mean - I don’t mind having the bar to be moved in its entirety over to the next system but not in half… I don’t want the musical info in a bar to split.
Now I know that there is reference to that in “staves and systems” i.e. “allowing open bar to be split across system” and I don’t have it marked but Dorico splits the bar like this anyways and so it seems that this instruction is note forced in the program very well or at all…
I know it is possible to workout accidentals manually in engrave mode for each and every chord… but this is very cumbersome and will take lots of time / work.

Any ideas?

Thanks in advanced and wishing you all a lovely day.

First off, you can find default settings for when Dorico will show cautionary accidentals etc in Library > Notation Options > Accidentals. Following Dorico’s top-down philosophy, this allows you to make the per-flow defaults the closest to the end result that you want, with the option to adjust accidentals on a per-note/chord level if needed beyond that.

Secondly, and I am sorry for being a broken record, but your questions would be much quicker, easier, and more pleasant to answer if you would please include at the very least a screenshot of the problem you’re experiencing, if not the project file! I know you’ve asked a few questions recently and have at least once shared a project, but it’s so much easier for people here trying to help if you make it easy for them to pick up on your latest question, and not expect them to search the forum for whichever thread you last shared a project in…

For example, it could be that

  • you already have system break signposts that are forcing system breaks in the middle of bars
  • the horizontal spacing in these systems is really full, forcing half-bar splits
  • the time signatures are set up in such a way that it’s forcing odd casting off

But none of this is possible to say for sure from a text description alone, I’m afraid.

2 Likes

First of all - Thanks very much for the reply.

My Q. didn’t relate so much to cautionary accidentals definition but more to accidental spacings.

1). I was trying to explain that I wanted to resolve this issue by increasing the value for min. short notes value but although I left unchecked the “allowing open bar to be split across system” DORICO split the bar across two systems.
So I understand that you believe this problem is due to have pointed out and thus I’ll resend the project.

I hope that there is a way to increase min. value for short notes and prevent a bar from splitting like this.
I think this will sort out this issue and will help (due to the nature of the work ) to achieve greater clarity for start changing accidentals for each instance where they are not space out properly seems to me as a needless cumbersome experience and I was looking for s more automatic straight through solution for this to happen, in fact I don’t think a user should be bothered with these issues to begin with…

3). I also want to apologize for making you feel as if you sound like broken record and I thanks you again for your willingness.
so I am attaching the project here again (there are some changes indeed from the previous one)

Few remarks.

The dotted bar lines are not bar lines but lines.
Accidentals issues - bars: 40,46,51,55,61,68,69,75,81.
I thing I’ll get more of these…
Also Issues of ties crossing note heads and meters some I tried to correct but looks a bit awkward though.
I had to reduce piano 2 fader because although they are both same instruments piano had dynamics issue.
Thanks again.
rites of nature and man 270324 - for review.dorico (1.8 MB)

Hi Ram, I’ve now had a look and thanks to some hints from my learned colleagues, have some suggestions for you:


Accidentals colliding

In Layout Options > Note Spacing > Advanced Options, switch the setting to “Use actual widths”. This lets Dorico do a better job of accommodating clusters of accidentals, and generally situations where notes have more stuff alongside them than “normal”.


Avoiding bars splitting over system breaks

I wouldn’t recommend increasing your minimum note spacing massively as a way to avoid bars splitting over systems: if anything, increasing the minimum note spacing is going to force Dorico to do that more often, because each bar now has a larger minimum width. I tend to find that setting values smaller, and inserting system/frame breaks as needed, is easier than making values larger and forcing bars back to the previous system.

You can lock the layout if you’re happy with how bars are distributed into systems, which prevents them moving around as you’re making further edits.


Page numbers

Your odd-numbered page numbers are in the top left corner, but still with the outside-edge paragraph style alignment. I suspect you copied the left side of the Default page template to the right at some point, and didn’t also move the page number text frame to the other corner. (The L-R / R-L copy function is absolute, not mirrored).

1 Like

Dear Lillie - thanks for the efforts you took to advise me so nice of you.
Many thanks.

#1 have already helped a lot to page clarity.

Will have to fully understand #3
( Interesting idea about the page #s… so if I understood correctly you think this has impact on items on the page… do odd #S has to be on the right side of the page?
I hope resetting the page template will not damage anything.
I’ll check carefully with your text right after my next question…)

cheers.

Page numbers can go anywhere you want – Dorico shows page numbers using tokens in text frames, so it’s the position of the text frame containing the page number token that determines where page numbers appear. You will often see page numbers on the outside edges (left on even-numbered pages, right on odd-numbered pages), but equally sometimes in the middle, or always on either the right or left corner.

You can have them always in the left corner if you want, that’s no problem – I only mentioned it because it didn’t look intentional, because the Page Numbers paragraph style was still clearly set to “outside edge alignment”. Meaning, on odd-numbered pages, the page number was against the right edge of the text frame, even though that text frame was now in the top left corner.

Easiest way to get this back to page numbers in the outside corners: edit the Default page template, then on the right page of the 2, select the page number text frame, and move it across the page.

1 Like