Avoid half whole note triplets

I was importing some notes from Midi and Dorico automatically displays them as half and whole note triplets (first line)
however I’d like it to be displayed like in the second line. Is there a setting like maximum value for Triplets?
Furthermore, how can I easily convert this. It’s a large score and happens often in many instruments.
So far the only option I found was rewriting it. Funny enough, when I write the second line, it stays like this and does not get convertet to big triplets

There’s no way to tell Dorico that this is how you want that particular figure to be transcribed from MIDI, I’m afraid, and I agree that probably the only way to achieve that result is to rewrite the result. You could try to make use of the Lock Durations feature to help you to quickly reinput the correct pitches after copying and pasting the desired rhythm to the destination instruments.