Avoiding the broken tie

Hello to all
Is there any way to avoid the broken tie in the stave that does not have the time signature?
Thank you

It looks like you have enabled Layout Options > Time Signatures > Show once per bracket and Layout Options > Time Signatures > Narrow, sans serif. My comments are based on that being the case.
The gap in the tie on the top staff is probably an unintended side-effect of the settings.
A workaround I have devised is as follows:

Delete the 6/4 time signature.
Go into note entry mode (double-click or shift-N) in the middle staff.
Open the time signature popover, enter 6/4, and press alt/opt-enter. This will put a time signature on that staff only.
Click on that time signature and choose Edit > Paste Special > Duplicate to Staff Above (or Below, as is appropriate).
Select the time signatures which now appear in the top and bottom staves, open the Properties panel and enable Time Signatures > Hide time signature.
Click on the time signature on the middle staff.
In Properties, click on Custom scale and type in the percentage you need to match it to the appearance you want - I found that 220% made it look pretty close to what you showed in your picture.

Hello and thank you for giving me some of your time.
The solution is perfect for 3 staves but for 2 I didn’t know how to do it and I used the text tool hoping that the engraving would remain stable.

Happy holidays and thanks again

Yes. I see what you mean with only two staves.
The background erasing seems to extend quite a distance beyond the actual top of the time signature.

In these images the erasing appears to be specifically on the staff where the time sig “came from”, as well as where the numerals are. Not extending a long way above them – note the unbroken tie on F. So possibly this could be fixed in future?

Just to say that I took a look at this tonight and we will indeed be able to fix the problem with the stray erasure appearing on the first staff in a future version.