Backup Strategy

I’m going to be rebuilding my system from scratch and would like to have some advice on a BU strategy. My thoughts:

  1. I’ve made an image of my OS drive with Acronis so I would, theoretically, be able to open up any folders/files on this list:

https://helpcenter.steinberg.de/hc/en-us/articles/115000245510-Preferences-of-Cubase-and-Nuendo

  1. Made a BU of my Kontakt libraries from Windows 10 registry so I can open up in the fresh install.

Any other advice? I’ve saved a lot of track presets and VST presets so I’m hoping they all transfer when I replace all the .xml files on the fresh system, but as Cubase places so many files in so many different places, I know it will be tricky. I know it will be a PITA, but would just like to lessen the headache somewhat. Seems like every time I plan ahead, I just give up and end up rebuilding everything from scratch anyway.

Same general question. Best practices for backup of Cubase DAWs?

I found this link very helpful:

http://vi-control.net/community/threads/sample-libraries-how-to-guides-to-migrate-to-a-new-computer-updated.37056/

From Guy Rowland:

KONTAKT

This always was the easiest - ironically for everything except the factory library. Simply install the program and dlls from disk (no other content), run updates, then use Add Library to point at all your 3rd party libraries and add your licenses either via Kontakt or Service Center (which I find more reliable for this task). Remember to copy across any scripts / multiscripts - you’ll find them in your documents folder /native instruments/kontakt 5 / presets / scrpts OR multiscripts. LASS owners - you’ll also need to reinstall the ARC - this is one click via the Audiobro downloader.

The Factory Library in K5 is another matter. Here’s what you need to do.

  1. Make sure you have 25gb of free space somewhere for temporary use only (it can be an external drive)

  2. Run the Komplete installer (or Kontakt 5 presumably), and check ONLY the Kontakt 5 Factory Content.

  3. When prompted, navigate the content folder to your spare drive (the first option is for the standalone app - normally you’d keep that on your C drive as it is very small).

  4. Install the library

  5. When done, go your temporary drive, and navigate to the factory folder / Samples. Delete the 6 subfolders in there of the main content (Band, Choir etc) but you must leave Kontakt Factory Library1.nkc and Kontakt Factory Library1.nkr.

  6. If you have installed this on a temporary drive, you can now cut and paste it to where you really want it - it is only 134mb in size, as opposed to over 23gb!

  7. Open Kontakt 5 - hopefully there is a new library tab for Kontakt 5. If not, go through the install library routine, pointing at the location of the Kontakt 5 library.

  8. Go to Files / Batch Resave, and ignore the warnings!

  9. Navigate the browser to your NEW Kontakt 5 library.

  10. It will then check for missing samples - might take a while.

  11. You then have various options to find the missing samples (around 45,000 of them). Click manually find folder, and point to your Kontakt 4 installation.

  12. Press go. Again, it might take a little while - on my system it was actually pretty quick pointing at an SSD.

  13. Viola! You now have Kontakt 4 exactly as it was with all old projects unaffected, and Kontakt 5 is equally pristine - but saving nearly 25gb of space on the way.

The only other thing to remember is to install any legacy versions of Kontakt you may have used so old projects will still work, in my case K3 and K4.

VSL

I’ve had some issues in the past, but all went very smoothly this time. Install latest versions of all your VSL software, the elcienser (and plug it in of course) then run directory manager. Add your locations, and that was it.

3 years ago I had a hiccup here, that the files for my Woods SE didn’t appear normally in Patches, but did in Matrix Manager.

Don’t forget to copy your custom data folder with your metaframes etc.

PLAY

Oh boy. In the past if you get this wrong, you pay. Three years ago, this fully had me at the brink of madness. Piotr guided me through the sheer horror of it all (which involved at least 50 install attempts). Full details on what eventually worked here - http://www.soundsonline-forums.com/show … hp?t=35599

Piotr now tells me that in Play 4 things are MUCH better. You should be able to just add libraries via the browser’s favourites box. First install iLok manager and driver to the latest version (and make sure your iLok is connected). Then install Play 4 (latest version) and tick all your libraries. Then just right click in the favourites pane to add your libraries one by one. This worked great for me on SD2.

I can also vouch for this following method, which Piotr says isn’t necessary any more, but to be ultra cautious its another option:

If you own any version of Symphonic Orchestra, INSTALL THIS FIRST from DVD. If not, pick any library for which you have an expansion (such as Symphonic Choirs or SD2). Otherwise just pick any random library.

Assuming you have all the samples on your Desired Hard Drive Folder (DHDF), make a copy of your sample folder to somewhere with some space, then delete on your DHDF. Next, install SO FROM THE DVD. When you choose the location of your sample library, pick your DHDF and make sure you have AN IDENTICAL PATH NAME to your original samples. When you get to the part when the library samples themselves start copying (after a minute or so), a new window will open labelled “installing”. At this point you are safe to CANCEL the install. Ignore any warnings. Now delete your new partial install folder (with just a few files in it, since you interrupted it). Now copy back your original full folder. Voila, all should now work.

The best thing then is to rinse and repeat for all sample libraries, then update Play to the latest version, ticking ALL the libraries you own. This worked for me without a hitch, however, I’d mislaid my SD2 disks. Fortunately, installing this via the favourites pane in Play worked fine.

ADDED INFO FROM member dbh, who had installed from the add library method:

In my situation (Cubase on W7) when I tried opening existing projects it wasn’t able to find the samples. The reason for this seemed to be that when you use the right click “Add Another Product Library” method it only stores the sample folder path in the CURRENT_USER section of the registry. It seems that when you open projects it looks in the LOCAL_MACHINE part of the registry for the product directories and can’t find them.

The solution is to recreate the same registry entries from CURRENT_USER in the LOCAL_MACHINE section. WARNING: Only do this if you’re comfortable updating the registry.

  1. Windows start > Run > regedit.
  2. Locate the HKEY_CURRENT_USER\Software\EastWest\Play\ProductInstallDirs key.
  3. Export it using right click export.
  4. Open the exported file in Notepad.
  5. Replace HKEY_CURRENT_USER with HKEY_LOCAL_MACHINE and save.
  6. Double click exported file to import new registry entries.

Now all libraries should be installed and working fine, also with existing projects.

ENGINE

Very straightforward. Install latest version of Engine, then (standalone) Preferences / Libraries / Add Library. Close, re-open. First time you load a patch you’ll get a “can’t find sample” box and an authorization notice. Follow the Challenge / Response procedure, close the dialogs, than you’re set.

SPECTRASONICS

Omnisphere / Trilian

Install the plugins, which appear first on your DVD installers. Then Cancel out when the installer starts on the STEAM data part of the process. Update the software to the latest version, then run the soundsource and patch updates (this will overwrite your custom settings like star ratings unfortunately - not sure if there’s a workaround?)

Run the plugin, authorize, then close and run again. It will ask you for the location of your Steam folder - point it in the right place. Close and restart - done.

NB - no need to reinstall the Moog library if you have it, when re-installing Omnisphere it seems to pick it up automatically.

Stylus RMX

A similar procedure to above failed for me. What ended up working was installing fully from disc (fortunately its only 2 discs), updating to latest versions of software and data then copying all my extra user files and folders into the correct locations.

ReFx

Nexus 2 - straightforward. Make sure the elicenser is in, then just install the latest software and on launch point at the content folder.

Toontrack

I haven’t been able to find any shortcuts that work, unfortunately. It’s all installs from scratch I’m afraid.