Bad HD performance at 96k

I got a project to mix that was recorded at 96k. I noticed two things about HD performance:

a) Whenever I move the playback cursor or a loop point to a new location or stop playback, the disk meter in the VST performance window goes to 100% for about a second. During playback it’s at almost 0. When I start playback at a new location there is no audio for about a second.

b) When I bounce a track to disk I get a “disk overload” error in about 50% of cases.

The project in question consists of about 30 audio tracks without any fx plugins. It makes no difference whether I play back only one track (in solo) or all of them. I have an RME Multiface II converter which is set at 1024 samples of audio buffer. My computer is a Win7 Pentium Dual Core 3.2 GHz with 4 GB of RAM. This is the first time I am experiencing difficulties with HD performance, but usually I work at 44k. My project HD is a fairly new 3.5" internal HD.

Any ideas what the problem could be?

You could try defragmenting your drive?

http://windows.about.com/od/maintainandfix/ss/SBSdefragWin7.htm

I’ve seen that in the past, also. Doesn’t seem to cause any issue with performance.
May just be an oddity caused by preloading of the playback buffers.

Wow, I wrote a pretty thoughtful post here about two hours ago and now it is not here? Weird. Eh, but maybe I am not supposed to talk about making adjustments to Win7, dunno. :confused:

Anyway, I suggest you make some adjustments to your OS, notably the file system and then the restore function. If the processor is redlining as you start a process, that’s all about accessing the HD. BTW, can you add more ram to your machine? That would be a plus in Win7.

Oh, BTW, if you are using a Dell or something that doesn’t have room for more ram, you can use a flashdrive for more ram in Win7. Google Windows ‘Ready Boost’. I havent tried it but it looks interesting.

The problem with readyboost is that it’s going to operate at a MAX of 480mb/s (for USB 2.0).
MUCH slower than internal RAM, probably not suitable for DAW applications.

Hm, maybe so about the speed of Ready Boost, I haven’t tried it. MS is suggesting it so I think it is something worth checking out. Too, it may be that the suggestion is more for laptops that desktops, I dunno. However my thought is, if you don’t have a lot of memory, it might be worth a try.

I also would reccomend this site’s tweeking suggestions for Win7, just scroll down the page: http://www.computingunleashed.com/speed-up-windows-7-ultimate-guide-to.html .

I think it addresses a lot of the ‘fixes’ that were important for setting up XP for recording back in the day of XP. The type of tweeking that AlienWare was known for and now has filtered down to gaming computers. (And of course a good gaming computer is a good recording computer.) As you run through the list of what they suggest, I have to say, I had no idea that Win7 had so much filler in the Games/Gadget catagory. (I would never open this or use it.) Funny thing, too, where I found it interesting to see that MS offers a gadget that shows you how much memory and processor resources you are using, I don’t need it.

(BTW, that gadget showed me something? Sitting at idle, reading an article on the web via Explorer, my processor was showing ‘0’ usage, but my memory was showing 22% usage. That’s Win7 as I understand it, using a fair amount of ram just to run itself. That’s almost 2G of ram, quite unlike XP. Which means, FWIW, looking at the OP’s 4G of ram - at best - he is running his 96K project on 2G of ram.)

What adjustments in particular do you have in mind?

I’m not going to add more RAM because I’m going to buy a new computer fairly soon anyway. This one is from 2008, and it wasn’t the fastest model back then.

I guess I just wasn’t aware how big a difference it makes whether a session is 44k or 96k. In the meantime I figured out that if I place the playback cursor at the bounce start point before bouncing I don’t get the “disk overload” error anymore.

My HDs are all defragmented. I did a quick read access benchmark test for the project HD and it came up with an average read speed of 75 MB/s. Average read access was 15ms. Are these values ok?

BTW, I did quite a lot of “system tweaking” when I installed Windows 7. I deactivated most of the visual fx as well as the indexing function and some unneeded background processes.

Not sure about the access time, but the read speed should be fine. A single mono track at 24 bit/96 kHz requires a data throughput of roughly 0,3 MB/s, so you should be OK for 260 theoretical tracks there… :sunglasses:

Understood concerning the computer replacement and ram. And it looks like you found a workaround, too. Great. As to the tweeks, that article was pretty complete IMO. One maybe important thing that I did learn from it that I didn’t know is that Win7 offers a ‘High Performance’ mode - and it is not the default mode so you have to select it if you haven’t already. Other than that, it sounds like you have done what you can do.

BTW, my test is always LoopMasher. I turn that on and start selecting the various patterns and choose between the various patterns in real time while I have my Cubase disc overload/CPU window up. I see a brief beat flash (in the Asio driver window) of 40% usage max on the most complex beats but the constant usage bars are under 5%. This covers anything I could want to do.

Some additional info on this (since I found I sometimes also have the ‘disk usage’ shoot up during locating): In the manual on page 24 is the following: “The overload indicator may occasionally blink, e.g. when you locate during playback. This does not indicate a problem, but happens because the program needs a moment for all channels to load data for the new playback position.”. I don’t get the ‘no sound’ during a second, so the OP also might want to check Cubase Disk Preload, under Device Setup > VST Audio System.

I think defrag is automatically scheduled in Windows 7, anyways.

I’ve seen (and used) recommendations in terms of access time (for audio that is) at 8-9 ms, so 15 ms would be on the slow end, but not having used such drive, I cannot comment on the impact. Since, like you suggested yourself, when re-locating the project playback position, at 96 kHz, then that may increase the blink time that Arjan mentioned from the manual.

I had read someplace that some people actually saw a decrease in performance when turning off some settings for the visual effects, which if that is the case, likely is because of some other related (maybe contradictory) settings.

Have you looked at the setting “Adjust for best performance of” under Advanced performance options?

Have you run a disk diagnostics at all? (Just to say that it’s been covered. :slight_smile: )

On this exact system, have you done any other ~30 tracks at 96 kHz before?

Do you really need to work at 96kHz?
I think if you google “problem at 96kHz” you might find more info and get a handle on whether it’s your system or DAW manufacturers BS and decide that you might not need to generate those large files.

Talking of large files, check any Cubase folders on your C drive as the backups in Cubase 6 might have overpopulated it.
First check your C drive for unexpected data growth!
Strip it out and redirect your backups (via Project Assistant, hidden at the bottom of the PA window) to another drive and then defrag if your C drive has got full.

I work at the usual 44.1 and I hadn’t noticed my C drive was enormously full. Your files will be even larger.

I have set processor scheduling to “background services”. All visual effects are deactivated except the basic Win7 design (without this Win7 looks worse than Win 98!!).

Have you run a disk diagnostics at all? (Just to say that it’s been covered. > :slight_smile: > )

Erm…no. Will do next time I’m in the studio. Is the program included in Win7 sufficient for that?

On this exact system, have you done any other ~30 tracks at 96 kHz before?

Not really, at least not a mixdown session. The only reason I’m at 96k with this project is that the guy who recorded the song gave me 96k files. Since I wasn’t expecting this kind of problem I thought I might as well do the mix in 96k.

Things are getting worse here…

Not only has the “disk overload” error come back, but now I am having all sorts of weird issues. Sometimes when I open a plugin its window is just a grey empty box and I can’t change any settings. Then I had a brutal system crash during a realtime bounce. I literally had to plug the cable from the computer to shut it down.

I am totally clueless as to why this is happening. My system is carefully set up and the system usage meter is barely at 50%. The are no background services eating up system resources either. And I think my computer should be able to handle a 96k session with 24 audio tracks???

I was thinking maybe there is something wrong with the system HD, not with the project HD. Maybe the disk diagnostics will shed light on this.

Case resolved. I contacted Steinberg support about it and it turns out my computer is just too slow. So I overclocked my CPU to 3.8 GHz and set playback buffer to maximum value. The session has run more or less stably since then. I guesss I just need a new computer if I want to work at 96k (which I don’t, but some customers insist on it).

Glad you found out the problem, FYI the above symptom is synonymous with running out of memory.

If you’re set at 44.1 any 96 files you Cubase asks if you want to change sample rate.
If you have that many customes asking for 96 files then upgrade the computer.

Chances are though that most customers wouldn’t know the sample rate had changed or wouldn’t even know why they were at 96 in the first place.
If they all do know what sample rate they want then (later, if you say you can’t afford an upgrade) I’d say they’re not paying you enough. :mrgreen:

make sure ur interface driver is updated too…
i had a tascam us800 that would lock up my computer.
i switched to a FP10, and have been quite happy since…z