Bar Number collisions (Score)

On a full orchestra score I generally put boxed bar numbers above the strings. Dorico’s layout options (screenshot 1) make avoiding collisions easy - on the staff set to show bar numbers. However, the bar numbers do collide with the stave above (screenshot 2). I would have hoped that Dorico would see all objects to avoid collisions. Is there a default setting that will automatically create space for bar numbers both above and below?

I don’t think there’s an automatic way to fix this, sorry.

There seems to be a wide gap above your vocal line. What are your ideal gap setting set to in Layout Options: staff-to-staff, group-to-group, and staff-to-group?

Perhaps your page is more cramped vertically than it needs to be.

Derrek, I tried reducing the Ideal Gaps settings. It did help with a few of the bar number clashes, but created other spacing issues I didn’t like.

I guess another question to ask might be if I can set a minimum Ideal distance only above Violin I. In the screen shot it happens to be the vocal above it, but depending on the optimization it could be harp etc.

No, you can’t.

I’m just thinking, and I don’t know if it’s possible, but you might be able to create a blank stave (or even use a one line stave) to put the numbers above?

Thanks, DanielMuzMurray. I think adding a hidden stave is the way to go.

This might help too:

I actually did this today because I coincidently have a client at the moment who requested bar numbers here.

This solution worked great. The only thing I had to do was:

  • remove the bar rests
  • adjust the default space between bar numbers and stave.

I don’t think there is a way to hide bar lines in one stave, is there??

The bar numbers seem a lot higher than 3 spaces. Is “½ Section” Text? If so, turn off Avoid Collision.