Bar Number / Stave Clashes

Hi everyone,

Just having a little head-scratcing moment with bar numbers. Please see the screenshot below:

I currently have bar numbers set to appear above the piano stave, however for this flow I have hidden a number of players between the double bass, and piano. In this case Dorico has still correctly placed the bar numbers above the piano stave, but this has caused a clash with the double bass stave above. I think this actually may be because the piano part is rather high ledger-line-wise, and perhaps this is causing the issue?

I’ve had a play with layout options, specifically the ‘minimum inter-staff gap with content’, but can’t seem to get this to remedy automatically without causing staff & system collisions, which means manually adding in frame brakes or without switching to engrave mode and manually moving staves around…

I have seen a post from Daniel a few years back about this, but was wondering if there have been any developments / does anybody have ideas of any newly introduced preferences etc I may be missing? Thanks a lot!


It may not apply to other circumstances, but in this case, why don’t you go back to treble clef in the right hand staff?

Hi Peter,

Thanks for the reply! Yes indeed, if I were to swap the clef back to treble the clashing issue is fixed (and, actually, in this case that could indeed solve my problem). However, if the instrument were to be a solo violin below the string section, who commonly read many ledger lines above the stave without 8va symbols, instead of a piano, I believe I would run into the same issue. I was just curious if this could be mitigated somehow automatically.

Perhaps this is just a specific use case where one must manually juggle staves around in engrave mode :slight_smile:

I think it’s the stem of the flat poking out in bar 78 that’s the proximal cause of how high above the staff the bar numbers are forced. It’s just bad luck that the flat happens to fall bang smack in the middle of the bar!

Thanks Daniel - noted.