Bar numbering question

I have a piece in which I don’t want the first 16 bars to be numbered and that bar 17 shows as bar 1. The latter is easy, but getting the first 16 bars not to show numbers by removing them from the bar count has to be done one at a time, sixteen times. Or am I missing something?

You can select all 16 bar numbers at once and use “Hide bar number” in the properties. That’s faster than 16 times “Add bar number change” and “Don’t include”.


Ah, you have to select the measures using the system track. That does indeed work, but it is logical to expect being able to do this in one go using the bar number change dialog and choosing exclude from numbering.

My apologies. Apparently I’d asked this question several years ago, although I think the dialog works slightly differently now than it did then.

I was thinking more of Ctrl-Clicking the 16 bar numbers and “Hide bar number” in the properties. I don’t think the system track can select bar numbers.

I guess that’s Cmd-clicking the numbers showing at the beginning of a system. When selecting the bars themselves in the system track, the Hide Bar Number option does become available in Properties.

This is one area I really hope improves with the 4.x cycle. I would personally find it much more useful if there was a toggle to SHOW bar numbers rather than hide them. (Ultimately, we need both.) I don’t want bar numbers in every measure, but I often desire them in specific spots (important musical moments that might not warrant a rehearsal mark, for instance) and it would be helpful to place them there. At the moment this isn’t possible and has to be faked with manually inserted bar numbers.

For some reason this is not working here. When selecting the bar in the System Track its bar number is not selected and therefore there’s no option to hide it in the Properties.

You have to select the bar number specifically.

The problem is, if you use the system track, it selects everything in that bar. The properties panel only shows you options that are available for what you have selected, and there are no properties that apply to everything in the bar, so it doesn’t show you anything. If you select only one or two items, the appropriate options will populate in the properties panel.

Yes, @Romanos , that’s why I was wondering how @Vaughan_Schlepp was doing the trick, when he said: “When selecting the bars themselves in the system track, the Hide Bar Number option does become available in Properties.”

Sorry, for some reason it’s now behaving as it does for @Juerg_Loeffler . I must have inadvertently selected differently before. I still think that the behaviour of the bar number change dialog isn’t logical and I agree with @Romanos that this area needs improvement.