Bar numbers at rehearsal marks

Bar numbers are shown at rehearsal marks, although it is disabled in layout settings:

https://www.dropbox.com/s/1k5rpxnvd4bc9gn/Screenshot%202019-12-02%2011.30.56.png?dl=0

This project started as an xml import…

It’s not a bug, but a problem with the XML. Try deleting the first time signature and re-entering it. XML sometimes has problems with meter.

Hi Dan, thanks for your reply. After doing some tests I found out that it has nothing to do with XML.

Dorico seems to hide bar numbers at rehearsal marks only if they are placed on the same side (top/bottom) of the staff.

https://www.dropbox.com/s/qs9uhhh6z1fwmva/Screenshot%202019-12-02%2014.59.21.png?dl=0
https://www.dropbox.com/s/lxu0nnqbhhuiomc/Screenshot%202019-12-02%2014.59.37.png?dl=0

Especially when using rehearsal marks that show bar numbers I would like to have an option to hide them even if they are on different sides of the staff.

I think that would look a little odd, personally, but to each his own. I’m glad it’s not a problem with XML.

Hi Dan, the question came up when I was asked to copy a given layout, where bar regular bar numbers were hidden hat rehearsal marks.
So it is not necessarily my personal taste :slight_smile:

Maybe the layout options dialog could grey out the corresponding option automatically if bar numbers are shown on the opposite side of the staff.
I think it can be confusing when you think you can choose between options that do not have any effect in the end.