Bar rest in 2+ voice

How do I type to get


Use Force Duration and rest mode (comma) to input them as explicit rests.

Could you please write the key sequence?

Shift-N note input
V for voice 2
O for Force Duration
Comma for rest input
8 for a whole note duration (assuming it’s 4/4)
Any letter A—G to input the rest

Disclaimer: I think this is right. If not, it’s very close…!


Ah yeah, bar rest is better…

Follwing the steps I get

Start with

Note input

Change to 2nd voice


Type rest

Press Return

No rest in 2nd voice.

What am I missing?

Edit: What the documentation is missing is that Rest Pos needs to be set. A piece of important information that should be in the documentation IMO.

Did you advance the caret to the next bar before pressing Return? Does that fix it?

If not, just select Insert Bar Rest from the right panel during note input for a quick fix.

I’ve made a note to check this.

1 Like

There is a notation option for this:

No need to enter anything. Just change the option.

1 Like

It seems like the “rest consolidation” in Dorico, that I thought was the removal of all “parallel” rests but one rest, is actually an overlapping of all rests.

Yes, but the piece I work on would then require that I split it in flows since the majority of bars should not display “parallel rests”. I feel that the use of flows for such a minor, temporary display (5 bars only), would be “overkill”.

I cannot advance the caret until I press Return.
Clicking the Insert Bar Rest button has no visual result, but it works, and the rests overlap, and I need to use Rest Pos in Engrave mode to separate them.
My expectation would be that the extra rest in the 2nd (or 3rd, or …) voice would “split” and be displayed separately when the rest is inserted, not overlap, but perhaps that is a limitation in the Dorico algorithm right now. A note in the documentation that a change in Rest Pos is needed for the rests would solve any confusion about the behaviour that looks like “nothing happens”. Lillie would look into this so perhaps it will be noted in a future version.

Of course, sorry.

You change the rest position in the properties. Than the second rest will appear.