Basic Audio CD burning keeps freezing up

When I go to create a basic audio CD I am getting mixed results even from the same file - i.e. same compilation of tracks. Sometimes it works perfectly, other times it freezes halfway through the operation. Sometimes it appears to have worked and I get the “Successful” message flashing, but then I go to play it back in my conventional CD player and it says “Error. Disc not finalized.”

During the scenario of the writing process freezing I click on “Cancel” the operation; it then takes up to 15 minutes to complete the cancel operation, and when it’s finished I can’t eject the CD. I have to reboot my computer to get the CD tray to open.

I’ve tried changing the brand of CD-Rs but this doesn’t help.

Any clues as to where I should look for a solution? Could I have a faulty CD burner? I downloaded a recent driver for it, and its only 6 months old.

I am using Wavelab 7 in Windows 7 64bit in an up-to-date computer.

First thing I would try, is another CD burner.

Thanks for response, Phillippe. If no other posts come up with alternative solutions I guess this will be the course I’ll try.

Can you not get hold of some freeware or use Windows built in burning engine to test your CD burner?


Thanks Jim.

It’s hard to test something that only faults intermittently. I have used my DAW (Cakewalk Sonar) to burn discs with no problem, but don’t do this often. I was hoping that someone on the wavelab forum had experienced the same issue and knew how to remedy it. That no one has come forward yet suggests it’s not a wavelab issue. As disc burners are not expensive I may still go with the idea of a new one.