Basic help with MIDI connection

Hello I am a new Cubase user and newbie in general. If there was a “Newbie” forum, I’d have sprung right to it. I am simply trying to record MIDI from my keyboard into Cubase and it’s not working. I have followed everything in the quick start guide and the manual that I could find to no avail. Are there any good resources for just basic troubleshooting on connections and set up?

I’ll try to describe what my set up is:

Keyboard is a Roland RD700SX. I guess it must be pretty old because it doesn’t show up on Cubase’s list of 10,000 keyboards that it talks to. It has 4 MIDI ports: In, Out 1, Out 2, and Thru.

My pc is a Windows 7 Dell. I have a MIDI USB cable with a MIDI In and Out. The In is connected to the keyboard IN and the out is connected to keyboard MIDI Out 1.

I have created a new project, added an instrument track, assigned a piano voice to it, enabled record and monitor. When I hit the record button, it looks like it’s trying to record something, and a little blue track content thingy shows up as the cursor moves along, but then when I stop, it all disappears and nothing I’ve played on the keyboard has been recorded.

The MIDI source is set to “All MIDI Inputs” and output is set to HALcion Sonic SE with Bright Acoustic Piano selected.

There’s another layer. About a month ago, which was the last time I had a chance to play with this, I was able to get it to record and recorded one song. At the time whatever I did to get it going seemed obvious so I didn’t write down everything, so i don’t remember what the trick was. But I do know that when I open that project, I can’t record anything new to it so whatever settings I had figured out are gone now. Also, when I try to play the recorded track, I can’t hear anything (but I hear audio from my PC with other programs).

So my guess is that I’ve just committed some kind of freshman mistake regarding channel/bank selection or the MIDI connection, but it’s frustrating because I have no idea how to troubleshoot it. Any help would be greatly appreciated, including references for basic setup, because if I’m having this much trouble doing this very basic task, I’m sure I’ll run into plenty more “AAARGHH - MAKE IT DO IT!!!” moments.

Thanks for any guidance,

Keyboards Midi OUT should connect to the Computers Midi IN and Midi in to Midi Out!

Out to In
In to Out

I’ve tried that way and every other combo - all same result. Just to be clear, though, I’m connecting to the pc via a USB port. Only one end of the MIDI cable has the MIDI in/out connectors. They are labelled IN and OUT. The cable didn’t come with any documentation so I can’t be sure what the reference point for IN and OUT is. Since it’s physically going to the keyboard ports, I’d be inclined to think that IN and OUT are relative to the keyboard but regardless I’ve tried both ways (including varying whether I use the Out 1 or Out 2 port).

Is there some way in Cubase to tell what devices you are connected to, or whether you are actually connected to any working MIDI devices? If my cable was bad, for example, what clues would I see within Cubase that would tell me that?

Please note that for this to work correctly:

  1. Connect the USB cable to the computer.
  2. Connect the “Out” (#1) from the RD700SX to the “In” on the USB cable.
  3. Connect the “Out” from the USB cable to the “In” on the RD700SX.
  4. Set MIDI “Local” to “Off” on the RD700SX. If you do not do this, you may end up with either duplicate keys sounding when playing, or a potential MIDI feedback loop (not very likely since the RD700SX has a thru port). You can skip this step, just to see that your machines are at least communicating.
  5. Set the global MIDI channel (sometimes called something like the “transmission channel” or “Tx” on some MIDI screen) on the RD700SX to “1”. This is usually already the case with Roland (except for drum machines and such).
  6. Create a MIDI Track in Cubase.
  7. Set the Input Routing on the MIDI Track to “All MIDI Inputs” (this CAN also be set specifically to the USB MIDI instance that should show in the drop down for the Input Routing, but for now use the “All…”).
  8. Set the Output Routing on the MIDI Track to the specific USB MIDI instance.
  9. Set the Channel on the MIDI Track to “1”.
  10. Play the keys on the RD700SX.
  11. Keep an eye on the graphical interface in Cubase for signs of activity, so you can troubleshoot if you get no sound. (Likely the RD700SX will already play the sound “directly” from the keys you are playing, so keep them eyes wide open for signs of life in Cubase!)

Think of a MIDI system as system of water hoses…

The water (you playing) comes “Out” (use #1) from the RD700SX and goes “In” (the In on the USB cable) to the computer, for Cubase to process. Record your stuff, apply MIDI effects, etc.

In order to hear what you are playing, Cubase echoes what is processed so, the water (Cubase now “playing”) is poured “Out” from the computer and goes back “In” to the RD700SX, which then processes the information and does what it is told (a.k.a. playing the keys that Cubase are sending).

This results is that it sounds like you are playing the RD700SX directly, but in fact you are not (or should not at least).

I’m not sure which list of 10,000 keyboards you are refering to here. Basically from within cubase where you selected “All MIDI Inputs”, you should be able to select your Roland RD700SX (but there should only be a few choices - not 10,000). If it isn’t on the drop down menu, then that indicates a driver issue with your midi cable. You can still select “All Midi Inputs”, just make certain that your device is on the drop down.


(Probably the Add MIDI Device in the MIDI Device Manager.)

fingerbreaker, don’t bother adding your device for the 10 pointer above! :slight_smile:

It was the MIDI Device Manager/Install Device list (actually about 120, not 10K - never very good at the jelly bean in the jar guessing games). So I don’t need to fret about my RD700-SX not being on the device list?

It’s not that I don’t get the concept of signals coming in and out, I just don’t find the nomenclature intuitive. Basically the cables are referred to in reference to the opposite piece of equipment you are connecting to, but the convention could just as easily be the other way around. But I get it now, and it’s not the problem.

Before I saw Elektrobolt’s very helpful post, I noticed the statement in the manual about making sure to make the MIDI connections when all devices are powered off. So I powered everything off, double checked my water pipe connections, and voila it works now. I hope to live in a time when we look back and say “remember how software used to be so sensitive that you had to do things like power off equipment before making simple signal connections?”. As a non EE/SW person, it seems unacceptable to me that it should make a difference. We can split an atom, send voice data across the world in real time, etc. but don’t connect your MIDI cable live or the system won’t register it properly.

Now I still have the problem that I can’t hear anything playing back but I’ll delve into the manual to understand the ins and outs of routing audio (haha) before coming back for help.

Really appreciate the responses - I’ll try to do my best to exhaust the manual before throwing more questions to the forum.


Yeah disconnecting and re-connecting the USB MIDI cable while Cubase is on (unless it has changed) is a bear because Windows will “remove” the ports and add them in again during the process. The MIDI connectors themselves on the other hand, can be unplugged and plugged back in at any time! (Just not the USB side of things.)

Give us a shout, should you need additional help, mate!

It might help to know that not all devices (speaking about the Roland) need such a detailed configuration for setting up the MIDI channel output and turning off LOCAL. I had to learn these things about the Roland Fantom G I have, but there a lot of MIDI Controllers, or “Plug & Play”, devices that don’t have sounds on them.

I found this to be a useful way for me to stop using the easy route of turning on my Fantom and just using that, versus loading Cubase and really spending time to learn the nuances so I can move just as fast in that system.

If you really get into MIDI and music production, you love having strong tools like a Roland Keyboard to do more complex MIDI setup and being able to record Fantom audio into Cubase, etc. The Cubase part will always be necessary for really fleshed out ideas that originate from the Fantom though.

This is my first post. If I did something wrong, let me know. I apologize if it is an obvious thing. Otherwise, I hope you found this useful!

Hi, I was going to ask if anyone knew how to connect MIDI to UR44, then I realise everyone here knew apart from me. i am trying to connect my Yamaha clp-240 to my UR44 which runs the AL9 version. somehow I can’t make it work, I connected with a midi cable, but can’t transport the data into the track. help, please! thanks