Basic Q’s about CbA7 Midi commands & keyboards

Greetings Steinberg Community:

As a newbie presenting my first post here, I’m also a newly registered user of Cubase Artist 7 purchased almost two months ago here in the United States. Despite my prior success with other DAW Apps I have used, I have a lot of learning curves to attend to regarding acclimating myself to Cb A7 properly and I look forward to putting in the time, effort and diligence that all must require.

But, for right now, I’m interested in receiving tips on how to isolate assigned midi out commands to Cb A7 from my Midi keyboard #1. (Without those commands bleeding over to my Midi Keyboard #2). running N.I.’s Komplete 8.

In another words, Cb A7 automatically assigns itself to channel #1. On Midi keyboard #1.(which is what I want when using LoopMash2, etc.). But on Midi Keyboard #2, when I assign Komplete 8 sound modules as “stand alones” from channels 2 to 16, the Cb A7 sounds still trigger anywhere on Keyboard #2 along with the Komplete 8 sounds.

Please bear in mind that I have yet to purchase an actual Midi Controller keyboard or stand alone control surface unit. So, I’m using QWERTY and my mouse in Win7 /64-Bit for right now.

For ASIO I’m using Motu’s Audio Express and their Micro-lite 5- port Midi USB port interface. The Audio Express i/o audio converter also has one Midi In and Out port which I am not using. All Midi and Audio Preferences are set up correctly within CB A7 regarding those two devices mentioned.

If screen shots are required by any of you upon request, I will be happy to supply them as may be instructed in my ongoing replies with you all.

Many thanks!

Respect & Appreciation,


Hi Martin.

Can you clarify something that doesn’t seem to make much sense on first reading.

If you haven’t purchased a midi keyboard controller…what exactly are the midi keyboard #1 and midi keyboard #2 that you are referring to ??

@ Grim:

Thanks for your reply. I didn’t think it was necessary to go into manufacturer details per each midi keyboard I mentioned using. However, I hope this layout I created will help you, and others, observe how I’m using these non-Midi Controller keyboards as triggering and playing tools for soft synth presently.

ALSO: I’m doing all this right now as “stand alone” for learning purposes. I haven’t figured out how to comfortably insert both Audio & Midi tracks to record within Cb A7 yet. This is a very involving prog and it’s going to take me a little time to get my first basic recording and mix-down tracks going. Which is fine. For me, this is the best way to take Cb A7 out for test runs and figuring all the learning curves ahead of me.

In the meantime, I hope the following graphic I designed helps explain better where I’m at right now and what I’m using:

Thanks again. I look forward to more thoughts and suggestions from you and others!

Respect & Appreciation,


Ah OK…so you do actually have 2 midi keyboards…you’re right that brands werre not necessary it just seemed like you might not have any physical keyboard at all.

Sooo, maybe this is the issue?
If you open the inspector section of the track list in Cubase and make sure you have selected a relevant instrumenttrack, does it say All MIDI Inputs above the instrument name?
If so you should be able to click here and select the specific MIDI port you want it to use.
Then your 2nd keyboard shouldn’t affect this track.

Back @ Grim:

Glad the graphics of both keyboards shown helped. Unless I misunderstood your instructions to inspector section of the track list in Cubase, by right clicking there where I laid some audio and midi tracks, there was no “All MIDI Inputs above the instrument name?” Just the usual channel strips, FX, etc. A section I am not very familiar with yet.

However, in File Menu > Devices > Device Set up, the MIDI Port Setup Window appears based on my setup and at the far right it says: “In All MIDI” and the x 5 Midi ports to my microlite are Active with blue X’s. Is this what you meant, or am I in the wrong place?:

Unfortunately, by De Activating Port 2, the Ensoniq (Midi keyboard#2) still plays Komplete 8 sounds unaffected. But, the DX 100 (Midi Keyboard #1) no longer triggers LoopMash2 in Cb A7. I can only start things in Cubase with the mouse.

► Hitting the reset button didn’t bring things back to where they were.

► Reading the embedded Help file was insightful. But, not helpful.

► Restarting Cubase also did not solve the new problem.

Any thoughts as to what I did wrong?


Respect & Appreciation,


Uncheck everything in the All MIDI column and select the specific port on the tracks. You might need the Input Transformer to filter the channels.

You’re in completely the wrong place…You want the inspector like I said.

Top left of project window do you see an icon with three rectangles?
Click on that and make the inspector visible…then follow my previous instructions.

I’d advise you put the device settings back as you found them.

Back @ Grim:

{Please view screen shot Jpeg attachment below}.

I reset all the ports in MIDI Port Setup Window as you advised. Then with a little help from a You Tube clip I found about Cb Inspector functions (and your original Inspector instructions), everything finally worked out as I desired. It was a little confusing at first, but as you can see on the attached screen shot, by disconnecting All Midi Inputs and checking micro lite: Port 2, I derived the exact Midi Port control separation I wanted between both Midi keyboards.

As you can also see on the screen shot, LoopMash 01 inserted as Trk#13 for Midi. You’ll see some other audio wav tracks called: “The Way” but, they were only x3 initially. I’ll have to figure out why so many other tracks are numbered, etc.

The point is, I succeeded at this quest thanks to your assistance and tutelage. Inspector function is starting to become somewhat better to understand and it makes sense to align it to just one track, instead of trying to do it the way I was in Device > MIDI Port Setup.

I’ve got a long ways to go, that’s for sure, but this post experience with you is def a great start.

Thanks for all the help, insight and assistance. I really appreciated it very much and look forward to interacting with you again.

Respect & Appreciation,