Bass Viola da Gamba ( = Bass Viol? ) playback does not reflect the 7-string bass


I’m transcribing some music for the 7 string gamba (range from AA on the bottom string) from a hard to read facsimile in order to have something to learn the music from. Notation wise everything is okay, but I notice that anything below C is not played back (and it’s marked in red as an “impossible note”). I assume that means the bass gamba is represented as a 6-string bass starting at the D one fourth above AA, which is sometimes detuned to C in order to cover a cello part.

So my request is that you modify the instrument’s range down to AA or to add a 7-string version of the instrument that starts at AA. FYI, the lowest string of the 7 string gamba is never tuned differently (that I know of)

/Daniel Enochsson

Marking out-of-range notes red is cosmetic. It doesn’t print (unless you print in colour) and you can switch it off with View / Note and Rest Colours.

If your low notes don’t play back, the problem is not Dorico, but the sample library you are using doesn’t include those notes. If you are using the bundled HALion library, it probably doesn’t have any viola da gamba samples but uses a cello instead.

You could change the sound to the General MIDI cello patch which doesn’t sound as good but has no limit to the playback range. (All the General MIDI patches in HALion have “GM” in the name, if you want to find them in the HALion window)

That’s a good point and turns out to be the reason why the notes didn’t play. Thank you! Of course the cello patch is not expected to have notes below C.
But now with the GM patch there’s another issue that a low note keeps sounding that I don’t have in the music. Any idea where it comes from? I’ve trimmed the piece down a bit and attach a sample here. This short segment still has the issue. The saved patch in my project is “[GM 043] Cello”
If I load “Violoncello Solo Combi” instead, only the notes in the piece plays. (And yes, I’m using the bundled Halion library)
Forqueray-Jupiter short (448 KB)

It sounds like the Halion GM cello is playing the keyswitch note. I tried it with Note performer and it plays fine. Note performer enables you to use extended ranges but it seems to do it intelligently. I use it while I’m working on a piece of music then I use better sounds when all of the notes are in Dorico.

You need to change the Expression Map setting for the GM instrument; the unwanted low note(s) you are hearing are keyswitches that are now playing as regular notes.

Change the expression map to “default” for GM instruments (Derrek’s post is correct, but it didn’t tell you what to change it to!)

Thank you all,

Changing the expression map setting helped. Not sure what an expression map is and why it would play back notes that aren’t a note-on/note-off MIDI event, but I’ll spend some time googling and I’m sure I will get the concept behind it. I’ve really not worked much with MIDI and I’m also new to Dorico.

Anyway you’ve been really helpful when I couldn’t solve my problem by searching the forum, so thank you again.
(Existing forum threads have helped me with a number of other issues so it’s a great resource.)

All the best,

Expression maps define how to translate playback instructions in the score (like arco or pizz for string instruments) into the MIDI data that the sample library uses.

Often, playback libraries use “key switches,” which are just notes that are out of range for the instrument, for these controls. This is convenient if you are playing the parts “live” into a DAW from a MIDI keyboard, because you can just press the corresponding keys to select what you want.

the HALion string samples use key switches, but General MIDI does not. If you use a HALion expression map with General MIDI samples, still Dorico generates the low notes, but the General MIDI samples play them as actual notes.

Even though “arco” is the default playback option for strings and doesn’t appear in your score, Dorico still sends the key switch to select “arco” at the start of playback. General MIDI samples don’t care the range of the real instrument, so the key switch “plays” as a low note.

The “Default” expression map ignores all playing techniques in the score (except dynamics,) so you don’t get any unwanted side effects.