Batch processing MetaData

Hi Everyone,

I cannot figure out how to batch process metadata properly.
When I load a preset file in the metadata window which includes the album artwork and then try to apply it on a bunch of mp3 files with batch processing it never works. I tried both the merge and replace option.

The next thing is, how can I batch process metada in a sequential order, the way it works with the naming scheme?
Lets say I have 100 audio files and want to rename them all with track title and track number from 1 to 100. This works great.
But how can I do the same thing with the track title and track number within the metadata automatically?

When I load a preset file in the metadata window which includes the album artwork and then try to apply it on a bunch of mp3 files with batch processing it never works. I tried both the merge and replace option.

Do you have this?
2020-03-31_09-30-31.png
Anyway, the batch processor is always decoding files and reencode them. Hence this is not good to process mp3 files. You should rather use wav files and convert them to mp3, with the proper metadata.

The next thing is, how can I batch process metada in a sequential order, the way it works with the naming scheme?

In the batch processor, the files need to be in the right order. Then, you must set processing to a single core in the batch options, else files are processed in parallel, hence in no order.

Do you have this?
2020-03-31_09-30-31.png
Anyway, the batch processor is always decoding files and reencode them. Hence this is not good to process mp3 files. You should rather use wav files and convert them to mp3, with the proper metadata.

Thanks PG, appreciate your fast support! That did the trick with the image file :slight_smile:


In the batch processor, the files need to be in the right order. Then, you must set processing to a single core in the batch options, else files are processed in parallel, hence in no order.

There are several issues here.
If you mean the execution tab and usage of processor cores, yes. 1 Task is selected here but it doesn´t work.
All files that I process are called track-name, track-nr.1

The problem with setting the correct order is that Wavelab auto-sorts the files in a wrong way and I can´t do anything about it.
E.g. a track with the name track 10 is always placed BEFORE track 2. It looks like this:

Track 1
Track 10
Track 11
Track 12
Track 13
Track 14
Track 15
Track 16
Track 17
Track 18
Track 19
Track 2
Track 20
Track 21
Track 22
Track 23
Track 24
Track 25
Track 26
Track 27
Track 28
Track 29
Track 30
Track 3

etc…

There is no option in the process batch window to sort the files manually by name.
But I´m not sure if the proper order in this window would solve my problem.
It seems that a Name Scheme option, specifically for MetaData is missing in Wavelab.

WaveLab auto-sort the files it adds at the same time.
If you add the file one by one, no sorting happens. I understand this can be cumbersome to add so many files.

But you could rename your “Track 1” to “Track 01” etc. to have the file sorted with eg. “Track 27”

Ok, this will indeed take some time but I´ll stick to it.
Thanks again for your help and support!