Battling with a USB mixer (help!)

Hi.

I’m a beginner recorder and I could use some help. I bought a Yamaha MG166CX-USB recorder a month ago and I’ve been trying to set it up (for guitar mainly). Obviously it doesn’t want to cooperate with me. I once got a thin sound from it but nothing ever since - I’ve no idea how I even got the thin sound back then. I’m using a VOX Tonelab EX as an amp simulator and I can hear my playing from headphones but I can’t get the signal to my laptop.

I’ve tried to record with Cubase AI 6 (came with the mixer) and Reaper. I’ve followed istructions when configuring but I might do something weird there, too.

So here’s what I do:

I plug in my guitar to VOX Tonelap EX input (I’ve tried straight to mixer’s line input as well) and the out put goes into the mixer [LINE]. I enable the recording [ON] and press the [PFL] down. The sound is in good quality as I play.
I open Reaper (Cubase is expired) and see that that there’s no signal going in. I check out the preferences -> Device:
Audio system: ASIO
Asio Driver: ASIO DirectX Full Duplex Driver (I don’t recall downloading any driver, is it on my PC already?)
(input) first: 1: Microphone (3-USB Audio C… - 1)
(input) last: 2: Microphone (3-USB Audio C… - 2)
(output) first: 3: Speakers (3-USB Audio C… -1)
(output) last: 4: Speakers (3-USB Audio C… -2)

After that… I’m clueless.

Again, I’m a total beginner and there might be something very simple I’m not understanding. I’d be very grateful if someone could help me to get started. Thanks.

Other info:

User’s manual for Yamaha MG166CX-USB (PDF) http://download.yamaha.com/api/asset/file/?language=nl&site=nl.yamaha.com&asset_id=8172

My laptop runs Windows 8, 64-bit. Intel Celeron CPU 847 @ 1.10 GHz

Hey, welcome to the forums :slight_smile:.
If your laptop is indeed running at 1.10 Ghz it might be a bit underspecced, but that’s a problem for later, it should work regardless I think.

I’ve never used Reaper so how the setup works there I don’t know, but I’m guessing it’s similar to Cubase. First of all, the DirectX driver might work, but it’s definitely not ideal. Check the Yamaha website for the ASIO driver for your mixer, and if they don’t have one (boo!), then get ASIO4All. (a free generic Asio driver that usually works much better.).

Once that is done, it’s all a matter of your setup in your recording software. You start by selecting the ASIO driver you want to use. In Cubase this would be in a dropdown menu in Device setup --> VST sound system (or something like that).

Next up would be selecting the ports on your mixer, and mapping them to busses in your software. In Cubase this would be in VST connections (shortcut F4).
Once you created busses for your inputs and outputs there, you can go ahead and create an audio track. Set the right input and you should receive input on that track.
Like I said, it might be called a bit different in Reaper but I imagine the general idea is similar.

Good luck!

edit: I just read that manual, it seems to describe the setup pretty much like I just did. I see they do indeed tell you to use the Direct X driver. I would’ve thought Yamaha would write a proper driver, but I guess not. I still recommend ASIO4all over DirectX though.

Thanks for the reply!

Downloaded ASIO4all and got signal to my laptop pretty much right away (awwyeah!). The sound quality is very bad, tho. It almost sounds like the recorded (guitar) was reversed. No VOX Tonelab sound at all, like I hear it. Also, I can’t hear anything (well, a very thin sound - like mosquito thin sound) when I try to play it when the headphones are still on plugged into the mixer. I have to unplug the headphones from the mixer and plug them into my laptop to hear my recording.

Again, I’m truly a beginner so it might be super simple stuff that I’m missing.

Thanks :slight_smile:

I suggest you try to get things to work without the Tonelab for now, once you know your signal chain works you can add stuff like that.
If you have to plug your headphones into your laptop to hear the sound, that means your output is not set up right. You don’t want to output your audio through your laptop soundcard, but to the USB interface in your mixer. If you open your ASIO4all control panel, you should be able to see all the physical in and outputs on your system. (you should see the yamaha USB in and outputs, as well as the in and outputs on your laptop.).

For now, disable every in and output in the ASIO4all control panel except the Yamaha USB. That’s just to make sure you don’t end up sending a signal through your internal soundcard someway. Do this while Reaper/Cubase is not running. (note that this will not affect your sound in windows/other programs in any way, only in software that uses ASIO4all as a driver)

With some luck, your software will default to the stereo output to the mixer next time you start it. If not, check the VST connections output tab to make sure it uses the Yamaha USB output.

Also check the output routing on your mixer. You probably have to press a button or 2 to route the output from the laptop USB to the headphone mix on your mixer.

Good luck!