Beginner here: why I can't see 'send' on a new FX track?

Hi all. I am trying to use Cubase for the first time. I’m getting my first music done but there is something I can’t solve.
I have 6 midi tracks and 2 audio tracks. Going to MixConsole I right clicked to create an FX Track. The track is there, the effect is on it, but I don’t have the ‘Send’ option like in all other channels. Therefore if I click on ‘routing’ the FX track is not listed, basically I don’t know how to route my channels onto that track.

Any help is appreciated.


You don’t need a send on the FX track. You need to send all other tracks to this fx track. Therefore you go to your Audiotracks and open the channel settings or use the “Audio Send” tab in the inspector. There you will find the fx Track as a possible destination.