Behringer X-Touch - any of you get this working properly?

Okay, got it operating as expected now, for the most part. The two things tha are still a problem are the Shift key and the inability to launch the plugin windows.

The Enter key is supposed to map to Shift, from what I understand, but I can’t get any shift functionality working.

I can select the plugins and navigate the params via the LCD, and if I change a plugin it does launch the window. However, once a plugin is added, I can’t find any button that will launch the UI for it, so I’m back to reaching for the mouse.

Anyone know how to fix this?

Hi Chris!
Unfortunately, I’m not (yet) in disposal of any (good neither bad) info concerning X-Touch working under C9.
Actually, after reading Your post I’m daunted by the idea of acqiring the Behringer controller (which I recently considered) -vs looking more willingly towords FaderPort 8…At least, Presonus list exact differences between “mis-functionalities” between few established DAWs, incl.Cubase, so there are no dissapointments, that their StudioOne is “in favor”…
But as I know myself, I WILL dig for any info on X-Touch, as -for me- it seemed better “user-configurable” than the FP8.
I’m not shure if the ONLY way to make the controller work EXACTLY the way I’d like it to work woul be (deducting from Your post AND from Presonus’s User Guide) to re-write /patch it’s commands list??? (Would be great business opportunity, I suppose…:wink:
Will still hount for and post any important info on X-Touch, IF I get to it. Cheers!

I don’t have the Behringer. Have the Mackie.

However, Control/Shift/Alt on the Keyboard and a press on the button that opens the channel edit window on the Mackie (and on the Behringer, I would assume) opens all plug in windows on the selected channel.
Control/Shift/Channel Edit button closes them.

Not exactly what you’re asking for, but convenient.

Hugh

Thanks, Hugh. At least it’s a mouseless solution.

The demo videos show him just pressing an encoder to launch the currently selected plugin, but like most extended functionality it’s only demonstrated in Logic. I know it’s possible to launch a single plugin because when you select a new plugin it fires up the window. Just not sure what the magic is to get an already loaded one to come up.

You’d think the same protocol would work the same on all DAWs. But then, I also believe in the Easter Bunny.

As a follow up for anyone else who finds this and wants info on the X-Touch with Cubase, I have more information at this point thanks to Robert Lofgren’s help and efforts over on the Behringer forum.

He confirmed (analyzed the midi stream) that the Enter key does in fact send the Shift code. For my initial testing, I tried mapping Shift + F1. He mentioned that there have been some known issues in Cubase regarding the shift + F key mapping in their MCU implementation.

I did a little deeper testing, using MCU / Cubase mode, and can confirm that the shift key does in fact work. Kinda sorta.

  • Shift + Master brings up quick controls as expected.


  • Shift + Sends, even though the Sends light starts flashing as expected, does not bring up the Cue Sends as it should, but rather just the plain old Sends.


  • The buttons to the right of Global View, providing 1 - 8 functionality, do work to bring up the configurations.


  • Shift + 1 - 8 has no effect and doesn’t invoke the functionality specified in the Remote Control doc, e.g. Shift + 2 doesn’t show the Audio Only.

Robert indicates that the X-Touch is a 100% compliant MCU protocol device and that anything which isn’t working properly is most likely tied to the Cubase implementation of MCU. Given the effort he’s put in to researching the behavior and analyzing the midi stream, I’m inclined to trust his assessment.

I was becoming frustrated by the fact that it’s so hard to get information on using the X-Touch specifically with Cubase, and because the Shift functionality was flaky had even considered returning it and buying an actual Mackie MCU. Based on Robert’s feedback, about all that would accomplish is spending another $500 to get the same bugs in a different hardware package.

While I don’t own an MCU, I do own a Mackie D8B and have had many other Mackie mixers in years past. The Behringer’s build quality isn’t as good as Mackie - plastic versus metal and generally a bit cheaper in feel.

Mackie support is also massively better than Behringer. When trying to get info from support about the Shift key so I could determine if I had a defective unit or not, I got an email from support that in essence said “It implements MCU, now please go away.” The only useful support I got from Behringer was Robert responding on their forums, which are largely a ghost town (they should stop paying their support staff and give him the salary instead).

With all that in mind, I’ll keep the X-Touch. Mostly because it fits in my console better than an MCU would, and only partly because a Mackie is double the price but would exhibit the same bugs in Cubase. If the Mackie fit I’d be tempted to buy it anyway because they’re a better all around company. This will be my last purchase of Behringer gear.

Hope these notes help anyone else who has purchased an X-Touch so they don’t go through the same frustration that I encountered.

Does any of what you reported make a difference if you switch Cubase from “Cubase mode” to “compatibility mode.” I don’t use the Mackie, but have a QconPro, and changing modes changes a LOT of QconPros functions. Personally, I like “cubase mode” much better because of the additional functions not available in “compatibility mode” but that comes with a disadvantage too.

When I first got it I tried both and ultimately went with Cubase mode. After that, I didn’t do any extensive testing in Compatibility mode.

Like you, I figured it was better to have the additional functionality. Also, either the v14 or v15 firmware specifically stated that it had updates to deal with the non-standards compliant Cubase >= 8 implementation of MCU. Since there’s little to no documentation or feedback from Behringer, it’s not clear if that means the controller requires the Cubase implementation after applying the firmware update, or merely tolerates it. So, I just went with Cubase mode.

That said, the Cubase remote control manual was pretty vague about what that “additional functionality” is, only that it existed. Is it documented somewhere in terms of what you gain / lose between the two modes?

I can’t find it. I’m thinking it depends on the DAW controller? Welcome to the world of MCU blind abyss.

I did find downloading the Mackie pdf a little help because a good portion of the Mackie pdf applies to the QconPro functions including some “secret” shift functions. But not all of course since the Mackie hardware functions are a bit different. I’m not sure if that would help with the Behringer, but you might check. By the way, the QconPro operating instructions are almost nil…like Behringer…just basic set up and then “you are on your own go find other users to help you out” perhaps because there are many different issues depending on the DAW.

fwiw, HughH who posted above, is pretty familiar with the Mackie-Cubase configuration so maybe he can help.

Thanks. I hope you guys saved me a seat near the crumbly part of the cliff. It’s more exciting that way.

You’re much kinder in that regard than I. While it’s true that there are multiple DAWs, that didn’t stop Mackie from testing to see how each one worked. They even created Lexan templates.

I’ts worth remembering that Behringer got their start by selling cheap knock offs of Mackie products without regard to intellectual property (if memory serves, there were quite a few legal tussles about that back in the day). It’s not a company I expect much from, and they certainly don’t disappoint in that regard. Quality aside, being IP pirates is one of the reasons I never bought their stuff. The X-Touch, however, is a controller that supports an open protocol that Mackie put out there for others to use, so I allowed myself a tiny lapse and gave them some money. Having seen just how little regard they have for their customers, there won’t be any further lapses.

Hugh is awesome. His shortcuts to show / hide all plugins for a channel made the difference between this thing being useful and me having to reach for the mouse every 10 seconds.

As for the Shift functionality, I’ll probably just live with what it does now that I know where the bodies are buried. Unless someone knows how to make the Shift command work that controls the Cue sends.

Hugh, do cue sends work on your Mackie?

My favorite post this year. Thanks. :sunglasses:

Yes. I also did a post back on CB7 when they upgraded all the features:

https://www.steinberg.net/forums/viewtopic.php?f=146&t=51282#p312935

It may help. Wrote it so long ago I’m not even sure what it says. I think others contributed, also.

Hugh

I calls it like I sees it. :slight_smile:

There’s a lot of great info in those posts. I’m not sure that I follow on the cues, though.

On the xtouch, there’s a button labeled Send. When I press it, the sends come up as described in the remote control doc. My understanding is pressing Shift + Send (i.e., pressing Shift + the same button you press for regular sends) should instead bring up the cue sends.

On your MCU, is this how it works? Press a button to get sends, press Shift + the same button to get Cues, or are you pressing Shift + a different button to get Cues?

Yes, that’s how it works.

I have a overlay for Cubase that renames the buttons (not all correctly) that came with the MCU.
The names etched into the panel are Enter and Trim - I think these were for Logic. So you may need to find these.

Multiple Shift(Enter)/Send(Trim) pushes cycle through the 4 Cue Mixes.

Pushing the send (trim) button directly brings up a Send Effects Edit Screen, not Send Levels from each channel.
Send Levels are accessed from a button called Plug-Ins on the
Cubase overlay (incorrect), and VPot Assign/Send on the original (Logic) etchings.

Maybe you are using Shift(Enter) on this button? Which will not bring up the Cue Mixes.
Using Shift on that button brings up an alternative Send layout.

Look for a “Trim” button if you do not have a Cubase Overlay.

A lot of the confusion stems from the fact that so many functions are different depending on the DAW.
But I helped a friend set up an X-Touch with Cubase and as I remember all the functions are there - you just need to find them.

Hugh

Please refer to my previous comment about the awesomeness of Hugh.

Cues are now working. What had me off track was the fact that while on the hardware there is in fact a Trim button, there’s also a Send button at the top (along with track, pan, EQ, plugin and instrument). However, in the template that Ralf provided on the Behringer site, I didn’t notice that he has two Send buttons - the one at the top, and also renaming the Trim button to Send.

With your observations about the Trim button, the Send Effects Edit Screen (which I didn’t even know existed) and the Send Levels, it all came together. The top Send button does in fact bring up the edit screen. The Trim button works as you describe in bringing up send levels, or with Shift the cue sends.

And with that, all of my major issues getting the X-Touch into service are solved.

Many thanks, man!