Being able to load the Aria player

In the upcoming update, will there be a provision for loading the Aria player into Dorico? It would be great if I could use some of the really good samples I’m used to using but without having to dig into Dorico’s guts and alter whitelists (whatever and wherever those are) or whatever else is necessary at the moment. Barring this, a really good set of instructions for non-programmers would be helpful.

No, there are no changes to the contents of the default VST whitelist in Dorico 1.0.10 (we are still discussing internally exactly what our strategy should be for listing further entries on the whitelist by default). You will still need to follow the procedure described in the knowledge base article, or the procedure that Cees Coenen kindly pointed out to you the last time you created a thread about this, here.

I believe the lines you need to add to your vst2whitelist.txt file for ARIA are as follows:

ARIA Player VST Multi

You need to find the entry in the defaults.xml file that will look like this:

and change the value from 0 to 1.

In theory, that should be it. You’ll still need to load the sounds you want to use manually into the ARIA player once it appears in Dorico, of course, because Dorico can’t load sounds into ARIA by itself.

I know that Cees Coenen kindly pointed the procedure out to me the last time I created a thread about this but it still assumes a lot of knowledge I (and probably a lot of other users) simply don’t have.

OK, I tried the above, copying the two lines into the vst2whitelist.txt file (I just happen to know about selecting show package contents, but this isn’t obvious to a lot of people, and otherwise you’d never find it). The value in the defaults.xml at the end of the int name field was already set to 1 so I didn’t change it. If it had been necessary, how to change it wouldn’t have been obvious, as the system tries to load double-clicked XML files in Dorico. Then I started up Dorico but now no player shows up in a separate window at all even though the sounds play back, so I neither know how to get the Halion window back nor do I have any idea how to load the Aria player or couple it to Dorico. While I was working on this, Dorico froze and when I tried to force quit it, the whole system shut down, something that hasn’t happened to me in years.

I just discovered that when I now start a new project from a template, the Halion window does appear. In all my existing documents, however, it no longer does. Fortunately I had the nous to copy the old vst2whitelist.txt to another location before changing it. Should I give up this whole endeavour and replace the changed one with the original one?

Maybe we can check the Aria Player version.
I’m not in my studio now, but I will help you if I can. We can speak Dutch on that moment :slight_smile:

I think you make an distake in the progress.

Go to Play mode, and look at the VST Instruments panel on the right-hand side. The little “e” button next to the name of the plug-in allows you to show the plug-in window. Use the drop-down there to see if the ARIA Player now shows up in the list there: hopefully it will.

You’re right that the knowledge base article doesn’t spell out that you have to right-click on the application icon and choose Show Package Contents. I will ask our support team to add that instruction.

Thank you very much for the help. I didn’t know about the VST instruments panel on the right and you were right, the Aria player showed up there and is functional. I’m very happy about this!

Could you help me find out how to do this? I can’t find the vst2whitelist.txt file. Where is it and how do I find it?

Any help would be greatly appreciated.

David Froom
(Mac user)

I have Garritan Aria Player (the standalone version) and it came with a VST plugin.

I found how to use cntr-click to open the package contents for Dorico, and found the vst2whitelist.txt file. I added the two lines, had to save to the desktop, give it the original name, then move it into the Dorico package as a replacement.

Next, I found and opened the defaults.xml file (had to open it in Dreamweaver). The specific line was not in there, so I added it in (copied from above, then changed the =“0” to =“1”).

Dorico is unchanged. In play mode, the dropdown shows only Halion and Symphonic Orchestra. No Garritan.

Any one have any ideas about what is up with this? Or can someone advise me on what to check for?

Thanks in advance,
David Froom

Try trashing the VSTAudioEngine folder in ~/Library/Preferences (where you found the defaults.xml file), and see whether the ARIA GUID shows up in there when it is recreated.

In the instructions I followed to accomplish this, I copied those two lines to the whitelist file, after which I was instructed to start and quit Dorico. Apparently this action altered the defaults.xml file, because when I checked it, the ‘0’ had already been changed to ‘1’. In any case, since then the Aria player is working well for me in Dorico.

I tried moving the the VST AudioEngine folder to my desktop (instead of trashing it, in case of problems). It was in ~user/Library/Preferences, and Dorico starting up did not recreate the folder. I put it back, and tried just removing the userpreference.xml file from that folder. Still no change when Dorico starts up.

In both cases, Dorico would play, and Garritan would not show up as a choice in the dropdown menu.

Maybe I need a very recent version of Garritan? Or could it be something else?

I’ll review my steps and try again when I have a chance. It isn’t super crucial, especially at this stage. I fear, also, since Garritan does funny things with MIDI commands (it has its own idiosyncratic way of using the ped64 midi command to make winds and strings play legato), it might not work flawlessly with Dorico?

Thanks, Daniel and Vaughan, for trying to help,

With the update, for some reason Aria shows up as a choice!

Does anyone know if one can set (instrument by instrument) slurs on and off points to connect to controller 64? That’s what Garritan uses for slurring for strings and winds. Without that, everything sounds detache.

Thanks all,
David Froom

No, I’m afraid there’s no support for the legato playing technique yet, but it is coming soon (hopefully in the next update).