best key signature in Dorico

when I import my midi file from Cubase into Dorico: it scores it in the key of “C” with a bunch of accidental sharps. But: I played it in Ab and would prefer it to be scored in Ab. It’s awkward to see it in C, with all the accidentals. Tried using the “key signatures” button in Dorico but while I can select all the notes in the song and choose the key signature for Ab to be shown at the beginnings of the lines great, but it doesn’t re-score the notes. Please advise.
many thanks
Steve

I am not sure what you mean by “re-score”… But if you add the key signature of Ab, then all that should happen is the accidentals go away. All of the pitches should stay the same.

Are you wanting to change the pitches also?


Robby

Here are some pictures to show that changing the key, keeps the pitches the same, but does remove the accidentals.



Robby

I played it in Ab in Cubase ARTIST 9.5…then I IMPORT it into Dorico: it unfortunately scores it in the key of C with tons of accidentals…I select it all in Dorico and try to transpose (is that an option in Dorico for imported midi files??.. I can use the key signature button,…but that’s just a cosmetic change adding the Ab key signature at the beginning of each line but not transposing the notes…

Did you invoke Edit> Reset appearance after adding the key signature? Or transpose up and down (a second or a third) to force Dorico to re-write the pitches, with its algorithms?
I have the feeling Dorico could face a problem like force duration which would be force pitches, when importing themidi file. Just guessing here…

Unfortunately, Cubase does not export key signature information in MIDI files, and Dorico cannot import something that’s not there.

I guess what confuses me some, is I would expect Cubase to export the correct pitches (Ab, C, etc.) however, since it does not export the key signature, I would expect that you would see all of the exact same pitches, but with a lot more accidentals. I would think that adding the key signature would then remove the now unnecessary accidentals but retain all of the correct pitches.

Unless I am missing something…

Robby

I would expect a MIDI export to export MIDI numbers, not note names. That is likely at the root of the problem. If CuBase does not export a key signature, notation programs would have to make a best guess for conversion. I imagine Dorico guesses “sharps.”

If you want different note names, an XML export is probably better if available.

Ohhhh… Now I understand your problem a lot better. I failed to understand the “sharps” part of your original post. I just read it as “accidentals”.

Robby

This might help…

Select all of the notes, and in the EDIT menu, go down to filter, and select all sharp notes. Once they are selected, press ALT + (plus), the should respell the notes up to flats. You can then add the Ab key signature, and the flats should go away.

Robby

MIDI can’t export specific note names: MIDI notes are made up of two bytes, i.e. two integers in the range 0 to 127: one represents the pitch, in chromatic half-steps, the other the velocity. There’s no way for MIDI to specify the actual note name and accidental, which is why programs like Dorico have to try and infer them from the musical content. Dorico doesn’t currently do the smartest possible job of this, though it’s something we intend to improve in future.

Thanks Guys

for transposing selected notes: the use of the ALT + technique versus just using the arrow keys to moves notes seem to be the trick, although I’m still struggling a bit to get a complete handle on understanding everything completely. I kept messing with it and did get it the way I wanted finally,

couple observations: Dorico’s TRANSPOSE function (in Write mode, under the Write pull down menu) is kinda hard to find: and kinda hard to use! Why doesn’t TRANSPOSE offer what most players want: an easy way to transpose up or down by half steps?? its goes up by second, third, octave,etc. but no half-step down? (I guess the selecting notes and using ALT + is quicker! but…anyways whew thanks that trick saved me.

steve

You can transpose by half steps using Unison (diminished — half step down / augmented — half step up)
It’s strange, it already has been reported, but it does work :wink:
You can also use the new popover shift-I and input t3 in the popover to transpose a third up

Anyone object if we change the Subject of this thread to ‘Respelling notes after changing Initial Key Signature’?

still wish there was a real easy quick straightforward way to go up and down 1/2 step with my melody lines in TRANSPOSE mode. I’ve seen the trick with the popover and t3 but: it’s something most pop singers probably won’t ever use.
What most singers who play piano want: to adjust their original songs up or down by 1/2 steps…to try singing in different keys: amazing to me that Dorico doesn’t get that…wow the alt + trick is useful and I didn’t know it til these posts by robby thanks. The TRANSPOSE menu is hidden and cumbersome!

You can use the shift-I menu to transpose a minor second up or down, I presume (t2m or t-2m if I recall correctly)

I am just in the process of importing music from Cubase to Dorico and I notice that for my needs it seems to work better via XML than via Midi.

Provided you own Cubase Pro I suggest to first tweak your project and to set all your key signatures in Cubase Score and then export to XML
Key signature and a lot of other settings will be read by Dorico.
BTW it is very fast and easy to “score-quantize” notes in Cubase Score!

Hmm . . . .

I seem to be having a similar problem. I only got Elements a few days ago - so its all still new to me . . .so, please excuse my inexperience :blush:

Basically, I exported a midi file from my Synth (Alesis Fusion) and imported it into elements.

It correctly imported the five tracks and created five parts . . . but similarly, they are all shown in C major . . .

The piece is in Db.

I used the Key Signature feature and managed to get 5 flats to appear correctly in the score, but the NOTES didn’t refresh,

so I still have C#s appearing.

I tried Edit>Refresh Appearance, but no change. I tried , and THEN Edit>Refresh Appearance, but still no change . . . .

Am I missing something basic here? Surely, this should not be difficult . . . .

ATB

parametric

Select all and type Alt+ (Alt and the plus symbol) and everything should be respelt using flats rather than sharps. Alt- (Alt and the minus symbol) does the opposite: it respells sharps as flats.

In the future, if it’s possible to add a key signature in your DAW before you export your MIDI file, Dorico will respect it. (However, if I remember rightly, Cubase for one doesn’t export key signatures in MIDI files, so you can’t take this initial step in Cubase.)