Beta VST3 not being registered in Cubase 11

We have developed a VST3 plugin. My first beta tester on Cubase 11 cannot get Cubase to register our VST3. I am on Cubase 10.5 and Cubase is “seeing” the VST3. Is there any difference in versions 10 and 11 that could cause this? P.S. the plugin processes only MIDI. Best, /Hans

I think this may happen because the beta tester has not all required libraries. Are you on Windows? You may need to install the “Visual C++ redistributable package”. See cpp-docs/ at main · MicrosoftDocs/cpp-docs · GitHub

Thank you Arne. The Beta tester also have Studio One, and Studio One registers and sees the VST3 plugin. Would this be consistent with what you suggest? Also, the beta tester has several other VST3 registered.

It still could be the issue that the Visual C++ redistributable package is not installed. Maybe all the other plug-ins link statically to the runtime. What about the other beta testers? Are they able to load the plug-in in Cubase?
Maybe it’s user error and he or she has a custom plug-in collection list (where new plug-ins won’t be added automatically).

Thanks Arne,
So the Visual C++ redistributable problem could just affect Cubase and not other DAWs? This is the very first beta tester and he has just received the plugin. He is kind of a power user, so I would expect his computer to be up to date. I am not a programmer by trade, so I am unfamiliar with some of these concepts. Would it be relatively common that VST3s be unrecognized by Cubase because of a needed update of the Visual++ distributable. I am asking because I would have to include something about this in the manual if this was the case. If it seems likely to be the problem I will ask him to install/update the Visual C++ distributable. Can he download this from Microsoft? Is he taking any risk to the configuration of his system by doing this?

You can switch to include the runtime statically if you want. You should check this out with your beta tester. It may not be the reason as stated earlier. There could be thousands of reasons for this issue. You have to nail it down with your beta tester. All I can do is make a guess on common failure.

Thanks Arne,

“You can switch to include the runtime statically if you want.”
Sorry but this is above my programming knowledge. My first question is if this could be the problem while at the same time there is no problem with the Visual C++ on other DAWs?

“You should check this out with your beta tester.”
The tester has refreshed the plugin list, the VST3 is saved in the correct location, he is pretty sure Visual C++ distributable has been installed for other software he uses.

“It may not be the reason as stated earlier. There could be thousands of reasons for this issue. You have to nail it down with your beta tester.”
The tester has a working setup for VST3 plugins in Cubase and other DAWs and the particular VST3 is seen and registered in Studio One. I’m at the end of my capability to troubleshoot it, and the tester has tried what he can. Is there any other reason that you can think of why the VST3 isn’t seen. What are the requirements for a VST3 plugin to be seen by Cubase?

The latest:

  1. I installed Cubase 11 on my laptop and Cubase cannot see the VST3 (the same problem as my beta tester has).
  2. I installed the newest Visual C++ Redistributable on the laptop but Cubase 11 could still not see the VST3.
  3. I took a different VST3 from my workstation (with Cubase 10.5) and saved it in ‘C:\Program Files\Common Files/VST3’ on the laptop. It shows up in Cubase 11 on the laptop.
  4. I installed the newest Visual C++ Redistributable on my workstation and built a new version of the VST3 in Visual Studio. This version is not visible in Cubase 11 on the laptop either.
    So even though the VST3 is built with the latest version of the distributable and Cubase 11 is using the same latest version, the VST3 is not registered in Cubase 11.
  5. I wanted to install Cubase 11 on my workstation side by side with Cubase 10.5 to test the problem there, but since I am on Windows 7 this was not possible because Cubase 11 requires at least Windows 8.

I would be extremely grateful if anyone could point me to the problem: Cubase 11 is not seeing the VST3 while Cubase 10.5 is seeing it.

How about building the validator from the SDK and copy it over to your laptop und then run the validator pointing it to your plug-in.

Thanks Arne,
I am not familiar with how to “build the validator from the SDK”. Maybe there’s a description of this somewhere. :slight_smile:

I think you should read the documentation of the SDK first and get familiar with it before releasing plug-ins: VST Home - VST - Steinberg Developer Help

I have read this, but not the technical specs from cover to cover. Is there a section about how to build the validator from the SDK?

Just build the SDK.

I have used Pluginval and there were some errors caused by a routine updating the interface. I removed the code and the plugin passed without errors. Still, the tester’s Cubase 11 cannot “see” the VST3, which is installed in …common Files\vst3. It doesn’t show up in Plugin Manager. He has also installed the latest Visual C++ Redistributable, but it didn’t change anything. On my computers, Win7 Cubase 10, and Win10 Cubase 11 and 10, the VST3 s is seen by Cubase. I wonder what criteria qualifies a VST3 to be seen by Cubase? Is Cubase looking to certain properties in the VST3? Could there be certain conditions on the user’s computer preventing it from seeing the VST3? He has a bunch of other VST3s that Cubase can see, and he is a very skilled and experienced user. Thanks for any further suggestions!

Cubase just calls the LoadLibrary API and retrieves the PluginFactory from the dll and extracts the class information out of it. If it works on one machine and not another, then it points to the plug-in and it’s dependencies.


Could you give an example of the dependencies? Wouldn’t the VST3 contain all necessary elements to function on any Windows Cubase installation? (except for the VC Redistributable)?

Everything you link with when you build your plug-in is a dependency that must be met when the plug-in is loaded via LoadLibrary. That could be anything.

This issue has been resolved. Here is the solution:
Visual Studio defaults to a “Debug” setting which affects the builds. Before sending a VST3 to a beta tester this setting must be set to “Release”. The problems described above were caused by the plugin being built in “Debug” mode.