Better CUBASE EXPERIENCE with Windows 7 over Windows 8?

Hey everyone- Ever since I built a new DAW (INTEL|CORE I7 5930k, 16G DDR4, SSD- 5 x 1TB) I’ve had continuous ASIO spike problems. It’s not Cubase though, because I also had strange audio spikes with ProTools. I have racked my brain out in trying to solve what is wrong with my PC and now wonder if it could be Windows 8. My last DAW was Windows 7 and ran like a champ. When I built the new one I went with Windows 8. Before I attempt a new reinstall reverting back to Windows 7, I thought I would get some thoughts from you guys on the matter.

Thanks in advance. :smiley:

On my system my perception is W7 provides a more stable environment. Issues can range from crashes to lockups. I’m not sure if it’s Windows, Cubase, drivers, or VSTs not playing as nicely on W8.1 but either way I kind of regret making the jump.

I upgraded from W7 rather than a clean install - I’m not sure if that makes a difference.

Overall Windows 8 has better performance working with multimedia and are faster on all other counts then Windows 7. So it shouldn´t work better with Windows 7, but there are always possibilities between specific individual setups. It can be example your audio-interface driver that don’t work good on Windows 8. Many do also wrong system tweaks, old XP tweaks on the new systems making it performed less.


Best Regards
Freddie

More likely, it’s something with your new motherboard.

Last time I build my machine, I had horrible spiking issues on a system that was supposed to be dramatically faster. After way too much time, I found out that it was the Gigabyte Tools provided by the motherboard company that was to blame.

My memory is a bit fuzzy on this, but if I recall correctly, there was a utility that was supposed to let me “tune” my motherboard. It played havoc with my DPC Latency. Got rid of it, and all was great.

I’m sure that you know about DPC Latency Checker - if not, do a few searches and you’ll find more good info than I can stuff into a simple post.

Hmmm…sounds interesting, BUT…I reinstalled Windows 8 yesterday and did not install the Gigabyte tuning stuff, and I also reset my motherboard back to the “default” setting, but still had the same problem. OH THE HUMANITY!!!

I haven’t used windows 8 to compare but I can also say that on windows 7, cubase 8 performs better than cubase 7.5 and that I don’t have any Cubase issues related to the OS.

I just updated my INF motherboard drivers (Z97) and it stopped spiking. I reckon Windows 8 will be better than Windows 7, but only after everyone’s finished writing the right software and drivers for it…

Very nice specs on your machine. I’m sure it’s frustrating to build a racecar and have it hang up. You don’t say which motherboard you used. Motherboard, or else video/soundcard hardware or drivers are the most likely culprits, assuming the Win 8 install was nailed.

There have been many issues with Intel’s new platform. The X99 chipset and DDR4 memory were really not ready for primetime when shipped to retail. Many of the motherboard manufacturers were still trying to work the kinks out of the new hardware. Some still are. Memory compatibility was a big one.

It’s better now, but if you have not already, you should definitely update to the newest BIOS (actually firmware these days) for your motherboard. Also, if you built the system yourself UEFI, AHCI and GPT are your friends. If those acronyms are not familiar to you, they should be. If your motherboard shipped with defaults set to Legacy and you did not change to the right settings, it can cause issues. I would also go to your minimum possible memory config to test and see if it makes a difference.

Are you experiencing true CPU spikes that are affecting your audio (audible glitches)? If so, your interface’s drivers might not be 100% Windows 8-ready. You might be able to work around it by increasing your sample buffer size in your interface’s control panel. Also, what kind of interface is it? A lot of people who moved to Windows 8 experienced problems with FireWire interfaces; some people were able to fix it by installing alternate FireWire controller drivers.

Assuming your drivers are up to the task, Windows 8 performs about the same for music production purposes. Sometimes a little bit worse, sometimes a little bit better.

This has objectively been proven to be false, particularly when it comes to DAW performance. The perception that Windows 8 is faster mostly comes from people who buy brand new (frequently SSD-equipped) computers with it pre-installed (it’s the computer that’s faster, not the OS), or people who do fresh OS installs on existing hardware (an out-of-the box OS install is usually snappier than an image that people have been using for years with tons of background services and startup tasks). Windows 8 does usually boot and launch apps quicker than Windows 7, but those improvements do not extend to actual runtime performance.

Microsoft also shoulders a lot of blame for some really deceptive pre-launch hype. The reality is that raw system performance between Win7 and Win 8 on identical hardware is about the same.

  1. Firewire are Apple technology that are total outdate technology. Firewire is DEAD and no more official support.

Apple Thunderbolt-technology are the replacement. Thunderbolt looks good on paper but not in reality so that is why Thunderbolt will not come to PC platform at all. The new USB3.1 (10 G-Bite per second transfer) that comes later this year will run over Thunderbolt completely. Much faster then thunderbolt, Plug and play, no drivers and 100% backward compatibility with older USB.
USB3.1 - SuperSpeed USB 10 Gbps (USB 3.1) from the USB-IF.


Check the video.
https://vimeo.com/20616954

http://www.usb.org/developers/ssusb


2. That Windows 8.1 has not better performance with DAWs and multimedia then Windows 7 are false.

Windows 8.1 are much faster, better performance working with DAWs, audio, multimedia and all other things.
There thousands of tests that show that conclusions. I don’t know why you keep state the opposite?


Best Regards
Freddie

I think some of my problems on 8.1 have come from a poorly configured system. I was pretty shocked when I ran latency mon and saw most of the meters running into the red - primarily caused by an intel ndis driver. Once I rolled it back it was much better. I’ve also updated the bios and made sure I have all the latest 8.1 chipset drivers etc. I haven’t tried C8 yet but hoping it will make a difference.

The only niggle I have is the hige number of page faults latency mon is throwing up. I can’t find any easy way to work out if this is a problem or not or what I can do to fix it if it is. Has anyone had experience of this before?

Hmmm…I am not familiar with “UEFI, AHCI and GPT” but will look them up and hopefully understand what you mean. :smiley: My MB is this: http://www.gigabyte.com/products/product-page.aspx?pid=5129#ov Ya, I think I should have waited 6 months to do my build to let the kinks be solved with the new X99/DDR4 technologies. " I would also go to your minimum possible memory config to test and see if it makes a difference" - Do you mean just trying out using only 4 gigs of memory (I have four 4 gig sticks)?

With a spare SSD drive I also installed Windows 7, but got the same ASIO spikes, so it definitely seems to be more likely a hardware issue. I originally updated the BIOS, but will check today if there is a newer version. I also tried several audio interfaces and had ASIO spikes. VERY frustrating!!! :angry:

The CPU runs like a champ, it is just ASIO related for the spikes. I tried out 3 different interfaces, all with the same ASIO spikes, so like I mentioned above, it is looking more like a hardware issue.

When I did a reinstall of Windows I left out the MB “tune” stuff, but still got the ASIO spikes unfortunately. DPC Latency Checker- Unfortunately it doesn’t work correctly with Windows 8, but I just downloaded LatencyMon 6.00 which does the same test I believe. I will be messing with that later today.

THANKS EVERYONE for trying to help me out. :smiley: I’m sure I’ll eventually get this figured out…before I end up pulling out all of my beautiful thick and lustrous hair. :stuck_out_tongue:

I think a lot of people miss the part of a new system or new BIOS which reset the BIOS settings and that makes performance worse.

I did the fix
turn off EIST stepping
and CPU turbo

on Gigabyte Z87 w/ haswell and that a big difference for ASIO. SB recommends these tunings.

You can check in Windows by running CPU-Z and it will show how the CPU jump around settings constantly. Thats not great for realtime.

Try that should help a lot. Also I will try a 20% multiplier increase and see how that goes. So far at stock my temps are very low at 30 degrees

edit: for the record on Gigabyte Z87 i5 4670 my bios settings in case somebody wants them:
load defaults settings
on board audio = off
on board graphics = off
EIST = off
CPU turbo = off
C1E=AUTO
C3/C6=AUTO


hyperthreading=on

Yes. It’s a pain, but to troubleshoot this, you should reduce your system to the absolute minimum hardware, but leave your audio interface in place. Boot drive only, minimum memory amount, all extra peripherals disabled, all other PCIe cards but video removed, etc.

Also, I would recommend that you disable your built in mobo audio in the BIOS. For a dedicated DAW, you don’t want it.

Get down to the minimum config and see if the spikes are still there. If so, you will have a much simpler task to resolve it. If the spike gets gone, add one piece of the puzzle at a time back in. If you cannot resolve the problem, you may have to get a different motherboard.

Relentless logic is the way. One step at a time. Channel Mr Spock! Crush the bug!

I would recommend to leave it enabled, but unconnected, set all Windows sounds to off, and the default output to the internal card.

If you like to use the onboard sound for listening to other things, then just make sure its output device is switched off during DAW sessions.

That way, if the OS or service or program decides it’s time to annoy you with a sound during a DAW session, it will NOT disturb it.

Note that some programs, like MS Lync, though generally not DAW/samplers, add sounds to Windows, which bypass the No sounds setting, and need to be turned off manually.

BY GEORGE I MAY HAVE IT FIXED!!! :smiley: I’m about to fall asleep, but played through a couple of project songs without any spikes. I installed the newest BIOS, de-pressed the OC button on the MB (didn’t realize the over-clock was even on), did the EIST thing, and other things that were mentioned here and elsewhere.

Thanks again everyone, and I’ll let you know if it is indeed fixed after I spend a day or two without any spikes…but so far I am happy…and very sleepy. :mrgreen:

Still looking good today! I finally even was able to use my Avid/Apogee ProTools Quartet with Cubase, and all was good. FINALLY!!! :smiley: It was a long 4 months of problems with my new X99 build, but now I feel like I can finally enjoy the fruits of my labor with this powerful system.

Thanks again for all the help and tips. :slight_smile:

Congrats. Enjoy.